x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Slanted images/buttons

I'm having an issue with images and buttons within UMG. I am trying to make a slanted UI like modern fps's such as Overwatch. However when angling the image or button in the UMG editor the sides of the image get really pixelated. Is there a work around for this or some settings that need changing with the textures?

The image shows 3 of the images in the bottom right which I have added a border around to make the pixelated edges less visible, however it would be great if I did not need to do that so I can make a really clean UI.

Thanks in advance!

https://gyazo.com/701d8382fc8bc312c8ab5175f9cb779f

https://gyazo.com/4dc0b3d516611cd4a7a1ac1e228a7b0f

Product Version: UE 4.8
Tags:
more ▼

asked Aug 11 '15 at 04:33 PM in Rendering

avatar image

DidsGG
34 7 9 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey MDidehvar,

This almost looks like an Anti-aliasing issue as your images have the 'stair-step' effect. This could also be due to your texture's property settings. Generally for User Interface and 2D pixels, unless you are going to be scaling them uniformly to increase their screen size, you want to use the 'Nearest Filter.' In your case, try setting it to Bilinear or Trilinear filtering to see if that helps.

Here is some documentation on Texture Properties and the texture editor UI to help you better understand this topic.

Texture Properties

https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Properties/index.html

https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Properties/Interface/index.html

Here is also an image as reference to the settings mentioned within the Texture Editor.

alt text

If none of these suggestions help, let me know and we can continue to troubleshoot.

Cheers,

Andrew Hurley

more ▼

answered Aug 12 '15 at 06:23 PM

avatar image DidsGG Aug 13 '15 at 10:27 PM

Thanks, this made them look a lot better without the stair step effect. You can still slightly see the stair step effect when looking in the sky but I guess I need to mess around with the settings more. Thanks a lot though, much appreciated!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question