x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Failing to compile new C++ projects

Whenever I try to create a new C++, a window pops up telling me that the compile failed. I seem to be getting this error:

 X:\Unreal\Epic Games\4.8\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5) : fatal error C1083: Cannot open include file: 'new': No such file or directory

When I compile it in Visual Studio I get the same error as well. I've read through alot of other similar questions here, but none of them have fixed my problem. I also noticed I don't have an error relating to windows.h, like so many others did along with this problem.

I've already tried to do these things:

  • Downloaded Windows SDK (both windows 8.1 and 10)

  • Building in Visual Studio

  • Provided links in visual studio like someone did in this post

  • I do not have non-english characters in my username

  • Verifying Unreal engine

I'm not really sure what else to do at this point, so any help would be appreciated.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 11 '15 at 05:51 PM in Installation & Setup

avatar image

Supercannon
1 1 2 4

avatar image Supercannon Aug 13 '15 at 01:40 PM

I guess it might help to know exactly what this "new" thing it's trying to import is. It seems like all my links to the windows SDK are good.

avatar image Matthew J Aug 13 '15 at 08:55 PM

It seems like it must be an issue related to SDK's due to what is trying to include. You can look in the file itself to see what it is trying to include and it is part of the standard C++ library. Can you try uninstalling those two Windows SDKs and only reinstalling the 8.1 SDK, link it, and see if that works?

avatar image Supercannon Aug 14 '15 at 01:27 AM

Just tried that, still get the same error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Alright looks like re-installing visual studio fixed it.

more ▼

answered Aug 17 '15 at 11:21 PM

avatar image

Supercannon
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
more ▼

answered Aug 11 '15 at 07:46 PM

avatar image

Shadowriver
37.3k 936 172 1116

avatar image Supercannon Aug 11 '15 at 10:39 PM

Just tried, but it didn't seem to fix the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question