x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Making new Static Mesh using BSPs, encountering problem:

I have an additive cone BSP and want to apply a subtractive cylindrical BSP to it and then make that into a new static mesh. I'm encountering a strange issue:

alt text

alt text

I'm somewhat new and have no idea why this is happening. It looks almost like the cylinder is subtracting from an invisible object, and the new dimensions that result are now visible... But there are no such invisible objects. The invisible objects also seem to emanate (for lack of a better word) from the cone brush. I'd really appreciate any insight on this problem. Thanks!

Product Version: UE 4.7
Tags:
more ▼

asked Aug 11 '15 at 11:26 PM in Using UE4

avatar image

Kelsomatic
11 1 2 5

avatar image AndrewHurley Aug 12 '15 at 07:51 PM

Hey Kelsomatic,

Be sure to build your geometry after editing your BSPs. I am also curious if this issue occurs in engine version 4.8.3?

Would you mind attempting to reproduce the issue in build 4.8.3? I have attempted to do this on my end, but am not seeing what you are reporting.

There is a setting within the 'Editor Preferences' to 'Update BSP Automatically' which can give you a preview to what you can see when the geometry is built. To find this option go to the Editor Preferences - Miscellaneous section.

Thank you,

Andrew Hurley

avatar image Kelsomatic Aug 12 '15 at 08:45 PM

I've tried building geometry and as it turns out the setting you mentioned has been on this whole time. I've discovered that this issue only appears once I change the scale of any dimension of the cone. It does NOT occur when I alter the scale of of the cylinder. Altering anything aside from the scale of the cone seems to leave everything as you'd expect. Not sure if this helps you better understand what's going on. Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thank you for the update. Were you able to reproduce this in 4.8.3?

I am not seeing this in either version of the engine. Can you reproduce this in your current engine version in a new project or does this only occur in this project?

Thank you,

Andrew Hurley

more ▼

answered Aug 13 '15 at 03:53 PM

avatar image Kelsomatic Aug 15 '15 at 05:04 AM

I was using 4.7.6 and I just moved the project to 4.8.3 and everything is working perfectly! Thanks for the tip!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question