x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Integrated Source Control: Repository (https) ignored, uses project repository (svn) instead

Hi!

Working with Unreal Engine 4.8.3, we wanted to try out the integrated Source Control when we bumped into an unexpected problem.

We have two ways of accessing the same repository: either via

  • svn://svnServerAlias/repositoryPath, or

  • https://svnServerAddress/repositoryPath

There are some minor differences in permissions and perforrmance, but the two can be used pretty much interchangably, i.e. while most of us the svn variant, the few colleagues who need to access the repository via https can commit their changes to the same repository without any problems.

For our Unreal project, we created a new repository, which we checked out using the svn path. Using TortoiseSVN, version control behaved as expected. However, we had problems logging in to the integrated Source Control.

Entering the svn path in the Source Control Login's Repository field always failed with "Unable to connect to a repository at URL" and "Authentication error from server" even with the correct user name and password.

We then tried entering the https alias instead, which also failed. Surprisingly, the error message is exactly the same, i.e. it looks like the Source Control is still trying to access the svn repository path.

alt text

At first we figured that the engine might have cached the previous Repository entry, but when we asked a colleague who hadn't used the Source Control before to try this, the result was the same. This led me to believe that the engine was pulling the repository path from the project's svn checkout path. To test this, I did another check out from the https address and then tried the Source Control login again, which immediately worked.

In summary: - Source Control only accepts "https" repository paths - Source Control appears to use the project's checkout path instead of the entered Repository, or at least check against it

We found a workaround, so this is by no means urgent, but it's at the very least confusing.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 12 '15 at 06:41 AM in Bug Reports

avatar image

erinacea
1.8k 69 28 113

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey erinacea-

I'm glad that you were able to find a workaround for this issue. I have entered a report (UE-20261) to investigate this issue further.

Cheers

Doug Wilson

more ▼

answered Aug 21 '15 at 05:53 PM

avatar image IUGO_Mobile Jan 16 '16 at 03:45 AM

Hi Doug, is there been any updates on this? We wanted to move from https to svn protocol, but as the OP mentioned, this flat out doesn't work on UE4. We tried UE4.10.2.

As we host our own SVN server, the benefits of using the svn protocol instead of https is massive. We avoid incurring a re-auth and pipeline teardown for every file when we use the vanilla svn protocol. This will be a massive boost to our editor responsiveness if the svn protocol is supported.

avatar image Doug E ♦♦ STAFF Jan 18 '16 at 03:14 PM

Hey IUGO_Mobile-

The reported issue is still open for investigation. I have updated the report since this is still affecting people, however I can't say for sure when a fix for this will be implemented.

Cheers

Doug Wilson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question