x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.9 Preview 2 Windows 10 Launch Problem

After installing the 4.9 Preview 2 release, and making a copy of my project I can no longer open my UE4 project by double clicking on it in Windows Explorer. I get the cannot build message, and to try and build the project manually. The build in Visual Studio 2013 does work. But I still cannot open the UE4 project from Windows Explorer.

I decided since the build worked in VS I would run the project via F5 (debug). Unfortunately I get the following error:

alt text

It appears to be a path error. From the screenshot it appears as though 4.9\Engine\Intermediate\Build\Unused is invalid. Are there any steps I can take to fix this?

This was originally reported in the forums: https://forums.unrealengine.com/showthread.php?78390-Is-engine-crash-while-compiling-c-code-a-common-thing

Product Version: UE 4.9 Preview
Tags:
invalid.path.jpg (74.9 kB)
more ▼

asked Aug 12 '15 at 10:41 AM in Installation & Setup

avatar image

Jerry.Richards
168 10 17 30

avatar image Matthew J Aug 12 '15 at 09:16 PM

Hello Jerry,

What type of error do you receive when you attempt to run the project via the .uproject file after building the project? Does it still say that it needs to be built? Have you tried opening the project from the Unreal Project Browser (The window that appears when first opening the editor).

Also, does this only occur with this particular project or does it also happen with fresh projects?

avatar image Jerry.Richards Aug 12 '15 at 10:11 PM

Well that helped me figure out what the real problem was: an incomplete conversion (most likely).

I made use of PlaySoundOnActor, which isn't supported in the 4.9.0 release. The problem though is that even after opening the 4.9.0 Visual Studio solution file and making the change the project is still not seen as a 4.9.0 project.

Trying to open the converted copy from the Unreal Project Browser kept asking to make a copy, or otherwise cancel, even though a conversion took place but "failed" due to a source code issue.

After making the fix in my original source, I then performed the conversion, which worked fine. Unfortunately I did encounter an error when running my game but did notice a stack trace in the error window (something that wasn't there before). At this time I'm in the process of putting the 4.9.0 Preview 2 through the motions and testing out my game, including debugging with VS 2013. I'll post a follow up shortly and also in the forum thread.

Please let me know if there's something specific you'd like me to do.

avatar image Jerry.Richards Aug 12 '15 at 10:23 PM

I can open the project as 4.9.0 Preview 2, and I can manipulate the items within the UE4 Editor.

However, pressing F5 in Visual Studio still gives me the bogus path as noted above.

avatar image Jerry.Richards Aug 13 '15 at 06:11 PM

The same debugging problem from Visual Studio occurred with UE4 Preview 3:

alt text

alt text

avatar image Matthew J Aug 13 '15 at 06:47 PM

It seems like it may be the project settings themselves in relation to Visual Studio. Can you check the debug settings in Visual Studio to see if they may be pointing to that directory?

alt text

avatar image Matthew J Aug 21 '15 at 01:51 PM

Hello Jerry,

We haven't heard from you in a while. Are you still experiencing this issue or was my last suggestion helpful to you? I would like to investigate further if you're still having problems. In the meantime, I'll be marking this issue as resolved for tracking purposes. If you would like to continue, please leave a comment and the question will reopen.

avatar image Jerry.Richards Aug 22 '15 at 06:26 AM

Matthew I'm still having the same problem, even with Preview 4:

alt text

alt text

alt text

avatar image Matthew J Aug 24 '15 at 08:29 PM

I'm sad to see that this is still occurring for you. I forgot to ask, do you have UnrealVS installed? That is needed to run in debug successfully.

avatar image Jerry.Richards Aug 25 '15 at 12:36 PM

UnrealVS is installed for 4.8.3. I didn't perform the process specifically for 4.9. Is that a requirement too? If needed, can the two installs live side-by-side?

avatar image Matthew J Aug 25 '15 at 06:50 PM

You shouldn't need a separate install for it, I just wanted to make sure you had it.

Have you given this a try with a fresh project as of yet or has it only been with your existing project? It would be helpful to know if this is project specific or not to help narrow the issue down.

avatar image Jerry.Richards Aug 25 '15 at 07:18 PM

That's a good point. Let me test it with a new project and provide an update later today.

avatar image Jerry.Richards Aug 27 '15 at 02:54 AM

Interesting. I am able to create and debug the Advanced Vehicle project with VS2013 and 4.9 Preview 4:

alt text

Do you know what the manual settings are supposed to be for the project? Maybe I could set them up so that I can test 4.9 with my own project.

avatar image Matthew J Aug 27 '15 at 08:06 PM

I'm not quite sure what project-specific settings could be causing this, but would it be possible for you to send a copy of the affected project? If you'd like to keep it private, you can send a link to me in a private message on the forums. My profile is here.

If it is based off project settings, it should occur for me as well.

avatar image ChrisWood STAFF Sep 01 '15 at 11:21 AM

Hi Jerry You could try comparing the NMake->Output property for the two projects. This should point to the editor exe. I think this is what VS uses to determine what it tries to run when you start debugging (unless it's overridden in Debugging->Command) Example Project Properties showing NMake settings

avatar image Jerry.Richards Sep 01 '15 at 10:19 PM

Chris,

For the most part the 4.8 and 4.9 NMake settings look pretty much the same. Please see the screenshots below.

alt text

alt text

4.8.nmake.jpg (107.9 kB)
4.9.nmake.jpg (103.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Which project is set as the Startup Project and what are the active build config and platform when you see this error? The BuiltWithUnrealBuildTool config in your screenshot above suggests these were set to something invalid.

more ▼

answered Sep 02 '15 at 01:47 PM

avatar image Jerry.Richards Sep 02 '15 at 02:28 PM

Chris (and Matthew),

To clarify, the project name in the images above were changed to protect the innocent, if that is what you were referring too. Secondly, and more importantly, the Startup Project wasn't set correctly. Something I didn't notice. It now works.

Thank you both for helping me with this.

On a slightly different note, when the project was migrated, and also when you generate Visual Studio project files from the context sensitive menu in folders, the newly generated solution file loses its filters. All hierarchy is lost. The project space is flattened. Do you know if this is fixed in 4.9?

avatar image Matthew J Sep 10 '15 at 06:35 PM

Hey Jerry,

I apologize but I'm not sure I understand what you mean by the hierarchy being lost. Could you give me an example? I haven't heard of an issue related to this so I'm not sure if it would be fixed or not in 4.9.

avatar image Jerry.Richards Sep 10 '15 at 07:48 PM

Matthew, the folder hierarchy in the image below is lost during the upgrade process. And I noticed this occurs when you recreate the VS project too. Along with the missing hierarchy the startup project is set incorrectly also.

alt text

avatar image Matthew J Sep 10 '15 at 10:09 PM

Ah, I see. If your hierarchy is made using actual folders instead of Visual Studio's filters, the hierarchy should remain but as these filters are saved in the .sln itself, there isn't a way to keep them from being erased when the .sln is overwritten during generation unfortunately. I've never seen it set the Startup Project incorrectly however. Does this happen with all projects?

avatar image Jerry.Richards Sep 11 '15 at 02:13 AM

I'm only converting (and working on) one project at the moment so I can't speak to the regularity of losing the Startup Project.

As for Filters vs. Folders, originally I used Folders but UE4 4.8.1, and 4.8.2 gave me problems. I could not access the folders under Sources in the editor. It was really frustrating so I resorted to using Filters.

May 4.9 is better. I'll give it a try.

avatar image Matthew J Sep 16 '15 at 09:23 PM

Hey Jerry,

Have you had any better luck with 4.9 so far? I'm interested to see if you're having any further issues since upgrading.

avatar image Jerry.Richards Sep 19 '15 at 12:06 AM

Hello Matthew.

Sorry for the delay in replying. I'm having other issues with my current hardware to the point that for real work it is basically unusable. For instance, if I try to calculate lighting my system continuously displays the "Building" message, even overnight. At the moment I have an i5 with 8GB of RAM, and onboard graphics, so the problems are expected.

Anyway, I'm about to purchase another machine and wanted to get your take on the configuration:

http://www.cyberpowerpc.com/system/Gamer_Xtreme_3000

It certainly will do better than what I have but I'm hoping that it actually excels at the job of building UE4, and my projects.

Once my new machine is set up I'll get back to testing the new release. Trust me, I've been patiently waiting, and now I'm anxious to get back to it.

Thanks, Jerry

avatar image Matthew J Sep 21 '15 at 06:21 PM

Hey Jerry,

I understand your predicament. I can say that the configuration for that computer definitely meets our minimum specifications and should be able to run the editor without any issues but I can't give any recommendations past that as it is out of my area of expertise. I would suggest making a post on our off-topic forums as the community may be able to help with suggesting a good setup.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question