x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Transparency in UMG not retained in viewport player

In UE 4.7.6, it seems that the alpha values are not being retained in UMG. When I'm building a menu with a transparent blue border (set by altering the brush colour) in the Widget editor, the menu takes on a solid blue colour when I run it in the level editor viewport. This is what it looks like in the editor:

alt text

Below is what the result is in the player.

alt text

Similarly, when I do something similar with the image and set an opacity value less than one, or attempt to add a throbber, the viewport does not seem to display it. It looks fine within the UMG editor.

alt text

But in the player, things are opaque. The throbber does not animate, and close inspection of the throbber shows that there are tiny x's inside.

alt text

I'm wondering what's the cause of this issue, and any help would be much appreciated!

Product Version: UE 4.7
Tags:
more ▼

asked Aug 12 '15 at 04:45 PM in Blueprint Scripting

avatar image

Infinite Zenith
3 1 2 4

avatar image Rudy Q ♦♦ STAFF Aug 12 '15 at 08:47 PM

Hello Infinite Zenith,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image Infinite Zenith Aug 12 '15 at 10:25 PM

Hi Rudy

Thanks for answering. I've tried reproducing the steps for both Unreal 4.7.6 and 4.8, and here's what I've done in a fresh project for both.

1) Created a new HUD (UserHUD) and a new Widget (WidgetTest) 2) Created a new game mode (CustomGameMode), and set the default HUD to UserHUD

alt text

3) In the HUD Blueprint, created an "event receive draw HUD" node, linked that to a "Create WidgetTest_C Widget" node (and set Class to "WidgetTest", then added this to the viewport.

alt text

4) In the WidgetTest, dropped a variety of transparent images, borders and throbbers. In the screenshot, I've only added a throbber.

alt text

5) Ran the game in the viewport.

alt text

What I'm noticing (and that I forget to mention earlier) is that the throbber appears to be animated once, and then stops. Similarly, transparent images usually are transparent for a few frames and then become opaque.

gamemode.png (248.2 kB)
hudblueprint.png (379.7 kB)
widgeteditor.png (317.9 kB)
result.png (1.6 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Infinite Zenith,

I was able to reproduce the effect that you are seeing on your end. However, this is working as intended. After seeing that you are creating and adding the widget to the viewport with the Event Receive Draw HUD I realized why it appears that your widgets are not showing as transparent. This is due to the fact that the Event Receive Draw HUD is called every frame. This means that you are creating a copy of the widget and adding it to viewport every frame. As they begin to stack up they become more opaque. Try adding the widget on begin play within the player controller instead. I hope that this information helps.

Make it a great day.

more ▼

answered Aug 13 '15 at 01:44 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Infinite Zenith Aug 15 '15 at 03:10 PM

Worked like a charm; thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question