x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Paper2D Unlit Sprite Affected by Lighting?

I am noticing some issues where as my paper2D sprite that has "MaskedUnlitSpriteMaterial" texture is darker at the corner of the screen compared to when it is at the middle. Also all my sprites are affected by lighting even though there are using "MaskedUnlitSpriteMaterial"

Things to note:

  1. Sprites are placed in the 3D world

  2. They all have "MaskedUnlitSpriteMaterial"

  3. Camera is orthographic

  4. No lighting/post process in the level

  5. I am using 4.8.3

Here are some comparison images:

  1. My default HUD position located at the top left alt text

  2. I moved the HUD to the center, now it is slightly brighter alt text

  3. Comparison of the shell icon

alt text

  1. All my sprite uses "MaskedUnlitSpriteMaterial" but when I set preview mode to lit, everything becomes darker. Unlit preview mode is what I want my game to look like. What is causing "MaskedUnlitSpriteMaterial" to get affected by lighting?

LIT PREVIEW (This is how the game looks when I run it) alt text UNLIT PREVIEW (I want the game to look like this) alt text

A good way to reproduce this is to find "DefaultSpriteMaterial" under engine and open it. Look at the preview panel, and change lit to unlit, the unlit version will be slighty brighter even though the material shading model is set to unlit.

This has been bugging me for awhile, is there any way to fix it? Thanks!

Product Version: UE 4.8
Tags:
img_darker.png (507.6 kB)
img_brighter.png (509.4 kB)
img_compare1.png (6.1 kB)
img_litlevel.png (505.1 kB)
img_unlitlevel.png (76.4 kB)
more ▼

asked Aug 13 '15 at 10:39 AM in Rendering

avatar image

SmileyJeff
136 12 21 30

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey SmileyJeff,

Thank you for your report. Fortunately, this issue UE-16928 has already been reported and fixed for the official 4.9 engine release. You can simply wait for official release to get the fix for your project. If you would like to test the issue, you can open a copy of your project in 4.9 preview 3 to see if it still occurs.

Let me know what you discover, or if you have any further questions.

Cheers,

Andrew Hurley

more ▼

answered Aug 13 '15 at 02:12 PM

avatar image SmileyJeff Aug 13 '15 at 04:32 PM

Sorry I did not go through the bug list carefully. I will port a copy of my project and test it on 4.9 preview 3. Thank you!

avatar image phil123456 Mar 09 '18 at 05:32 PM

so is this fixed ? it appears ok in the editor when I use unlit option but once the game runs, all sprites arelit althought I have setup an unlit material for my sprites

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question