x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game crash on Android Lollipop

I have this game that used to work fine on my Android 4.4.2 phone.

Since I updated my phone to Android 5, the game no longer works. It crashes on start.

What's weird is that it generates no log at all on the Android Device Monitor, filtering by the tags UE4|Debug. Other logs (not related to UE4) are there.

The device is an Asus Zenfone 5 (ASUS_T00J); Android version is 5.0. Using UE 4.8.3.

I have also tried changing NDK API Level to android-21.

Here's a version of the game, with NDK API Level set to android-21.

And here's another version of the game, with NDK API Level set to whatever the default was. This is the version that used to work on Android 4.4.2, before I updated my device to Android 5.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 13 '15 at 05:47 PM in Bug Reports

avatar image

Ixiguis
1.2k 58 61 253

avatar image Samantha Sutton ♦♦ STAFF Aug 13 '15 at 08:22 PM

Hey Ixiguis,

I was able to install both of these files you provided onto the Nexus 9 Android version 5.0. If you could please provide the logs from the 'monitor.bat' file from NVPack, that will be much better for us to sort through and figure out why it's crashing.

Looking forward to hearing back from you, thanks!

avatar image Ixiguis Aug 14 '15 at 03:40 AM

Hey,

Just to clarify: I am also able to install the game, the problem is that it crashes upon starting.

Here's the full log (no filters).

log.txt (524.4 kB)
avatar image Samantha Sutton ♦♦ STAFF Aug 17 '15 at 07:16 PM

This is the error that you're receiving when the game crashes on your device:

 08-14 00:34:05.082: I/DEBUG(22153): signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------

This looks like a driver crash in POWERVR_SGX544.

Basically, this is a GPU driver that's crashing when your project is launching. Are you able to push this project to a different device? If not, are you able to see if regular blank, no starter content templates from UE4 are causing the same crash?

Thanks!

avatar image Ixiguis Aug 17 '15 at 08:15 PM

The only other device I have is another Zenfone 5, but still running Android 4.4.2.

A blank project (First Person BP, no starter content) works fine on the 4.4.2 phone, but still crashes on the 5.0 phone.

avatar image Ixiguis Aug 17 '15 at 08:18 PM

Here's the log for the FirstPersonBP project on the 5.0 phone.

The project is called "deletemeeeee" if you wanna do a search. (I have too many projects here, gotta know which are safe to delete :P )

log.txt (550.7 kB)
avatar image Chris Babcock STAFF Aug 18 '15 at 03:46 PM

I found an issue with Houdini with some versions of the NDK and version of Android. A fix is in for 4.9 as of yesterday and is now in 4.9 preview 4.

avatar image Ixiguis Aug 19 '15 at 02:36 AM

I built from source (4.9 branch, downloaded some 5h ago) and it's still crashing on Android 5.0.

Log

log.txt (44.3 kB)
avatar image Chris Babcock STAFF Aug 19 '15 at 03:46 PM

To help rule out Houdini as the cause, please try building an APK for x86 instead of ARMv7 and see if it behaves the same. The crash dump shows it happening in the GPU driver but I was wondering if Houdini was contributing to the problem.

avatar image Ixiguis Aug 19 '15 at 04:05 PM

Huh how do I do that?

In Project settings -> Android -> Uncheck "support armv7" and check "support x86", then package?

avatar image Ixiguis Aug 19 '15 at 05:45 PM

Nope, didn't work. Log

That was a fresh C++ First person template, no starter content.

log.txt (62.2 kB)
avatar image Chris Babcock STAFF Aug 19 '15 at 09:23 PM

Ok, this gives us a better stack. Looks like it is happening in InitDebugContext calling glIsEnabled(GL_DEBUG_OUTPUT_KHR) in AndroidES31OpenGL.h. This is an attempt to run ES31?

If so, try replacing the call with bDebugContext = false; and see if you get past this. The driver may not understand this property.

avatar image Ixiguis Aug 20 '15 at 12:04 AM

If so, try replacing the call with bDebugContext = false;

Did you mean changing D:\UnrealEngine-4.9\Engine\Source\Runtime\OpenGLDrv\Private\Android\AndroidES31OpenGL.h? I changed to this:

     static FORCEINLINE void InitDebugContext()
     {
         //bDebugContext = glIsEnabled( GL_DEBUG_OUTPUT_KHR) != GL_FALSE;
         bDebugContext = false;
     }

Compiled and packaged the game again, and it's still crashing. Log

Regarding the ES3 question... I think it should be running ES2... this is what my project settings looks like:

alt text

log.txt (54.3 kB)
untitled.png (234.3 kB)
avatar image Chris Babcock STAFF Aug 20 '15 at 03:19 PM

InitDebugContext() is empty for ES2. Try adding some logging messages in FPlatformOpenGLDevice::Init() in AndroidOpenGL.cpp:

 FPlatformMisc::LowLevelOutputDebugString(TEXT("Before first InitDebugContext"));
 InitDebugContext();
 FPlatformMisc::LowLevelOutputDebugString(TEXT("After first InitDebugContext"));

etc.

avatar image Ixiguis Aug 20 '15 at 07:44 PM

It's crashing on the first InitDebugContext:

 08-20 16:38:05.339: D/UE4(1061): Before first InitDebugContext
 08-20 16:38:05.339: E/IMGSRV(1061): debug.c:1336: Debug assertion failed!

[Full log][1]

I'll try to run the game with VS debugger attached on the weekend (never done that before, don't even know if it's possible), to see if I can figure out where and why it's crashing in InitDebugContext.

Other ideas are welcome :)

log.txt (71.0 kB)
log.txt (71.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Ixiguis,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Aug 25 '15 at 08:23 PM

avatar image SalihBalkan Nov 21 '15 at 08:34 PM

I am having the same problem with my Zenfone 5 (A501CG) and Unreal Engine 4.10. After I update the software from KitKat to Lollipop, EVERY Unreal Engine 4 made games started to crash on the splash screen. Not only my projects, I also tried games from the Google Play such as "Sumotori Rolling", "Undead Blackout Free" and "UE4 FPS Test"; but result is same... Only Epic Citadel worked well, but it is made with UE3. Unity-made games are also work well.

Please write this bug to your list.

edit: One minute ago, I have tested TappyChicken with UE4.9. Even this 2D game has crashed.

avatar image Samantha Sutton ♦♦ STAFF Nov 25 '15 at 09:31 PM

Salih,

Please upload your crash logs from the Android device to your next reply. You can obtain them by using Monitor.bat which is located: C:\NVPACK_TADP\android-sdk-windows\tools

Thank you!

avatar image Reuniko Nov 26 '15 at 08:48 AM

Hello! Having the same problem, phone: Asuz Zenfone 5, model: T00J, all gamesrun perfectly on Android 4, but after update on Andriod 5 all UE4 games crash.

Versions: UE4 - 4.10.0 Andriod - 5.0 ( http://www.asus.com/en/support/Download/39/1/0/2/96nqlxHp1VKV4Rdz/32/ -> Firmware -> Version WW_3.24.40.78 )

I've obtained some logs from Android device, game is TopDown BP, there is 2 last rows:

 11-26 11:32:56.495: E/IMGSRV(13702): debug.c:1336: Debug assertion failed!
 11-26 11:32:56.495: A/libc(13702): Fatal signal 6 (SIGABRT), code -6 in tid 13726 (Thread-5417)

link text

log.txt (5.7 kB)
avatar image Samantha Sutton ♦♦ STAFF Dec 01 '15 at 09:45 PM

Reuniko,

Do you have another device you're able to try on, perhaps a Samsung Galaxy S4? It looks as though your device is having a driver crash in the PowerVR SGX544MP2 (GPU).

avatar image Reuniko Dec 01 '15 at 10:42 PM

No, i have not. Perhaps it is ASUS's failure, perhaps yours, I dont know, just tried to help, but i cant trade no longer, I did downgrade back to ANDROID 4.2, all works fine, feel myself happy.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

InitDebugContext should be empty for ES2 (comes from FOpenGLBase in OpenGL.h). For sanity sake, throw some logging into this empty function and into AndroidES31OpenGL.h with a different message just to see if it somehow got there instead.

more ▼

answered Aug 21 '15 at 04:25 PM

avatar image

Chris Babcock STAFF
1k 11 110 35

avatar image Ixiguis Aug 21 '15 at 05:11 PM

I put logging on those two places you suggested, and none of them were hit.

I also put on the beginning and ending of InitDebugDevice in OpenGLDevice.cpp. It printed only the "begin" one.

avatar image Chris Babcock STAFF Aug 21 '15 at 06:58 PM

Ok, then try just returning at the beginning of InitDebugContext in OpenGLDevice.cpp.. one of these calls likely doesn't work on this driver. Possibly the GL_KHR_debug.

avatar image Ixiguis Aug 25 '15 at 10:56 PM

Sorry for the delay. Returning at the beginning of InitDebugContext OpenGLDevice.cpp solved the problem. The game ran fine on the same Android 5.0 phone. Thanks!

Now the question is, what's wrong with it, and what to do to ensure it works without having to ignore that function call?

avatar image Chris Babcock STAFF Aug 26 '15 at 06:24 PM

I looks like the issue is needing to remove GL_AMD_debug_output since it doesn't work with the PowerVR driver on Intel-based devices properly.

This did not make it in for 4.9 but will for 4.9.1 hotfix. You can get the proper fix from this GitHub commit: link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question