x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Out of video memory error while working on data table

I'm attempting to make entries into a data table (contains 3 name fields and a custom data structure with 12 floats). After opening it, some time between 3 seconds to 2 minutes, I will receive the following error.

"Out of video memory trying to allocate to a rendering resource. Make sure your video card has the minimum required memory and/or closing other applications that are running. Exiting..."

I'm not running anything else, I only have a blank level open in the background, and I've just installed the latest graphics drivers to my machine (video card is a Nvidia GTX 670M, onboard video is Intel HD 3000) and restarted my machine. I'm including a text file of my dxdiag.

Has anyone else encountered this issue within a data table? I have been working heavily in UE for almost 6 months now and have not had an issues until this. Thank you in advance! link text

Product Version: UE 4.8
Tags:
dxdiag.txt (38.0 kB)
more ▼

asked Aug 13 '15 at 10:15 PM in Bug Reports

avatar image

ElChipacabra
141 3 10 18

avatar image ElChipacabra Aug 14 '15 at 10:35 PM

I've set breakpoints in my blueprint - any time I hover over a variable that uses this data structure, I get the same error and the editor crashes.

I've tried recreating and re-adding this data structure. Nothing has helped so far. Has anyone else seen this? Any ideas of something that I should try?

avatar image Shadowriver Aug 15 '15 at 04:05 AM

I think Intel HD might be issue here. If not keep in mind that now days desktop is also GPU accelerated and they are polygons and textures

avatar image ElChipacabra Aug 16 '15 at 01:45 AM

Unfortunately, I think you might be right. My co-developer has no issues with the data tables/structure. I've even gone through the steps of setting my Nvidia card as the primary card for the UDK: http://www.google.com/url?q=http%3A%2F%2Fknowledge.autodesk.com%2Fsupport%2Finfraworks-360%2Ftroubleshooting%2Fcaas%2Fsfdcarticles%2Fsfdcarticles%2FHow-to-force-your-laptop-to-Run-with-Graphics-Processor-vs-the-default-Integrated-Graphics-for-InfraWorks.html&sa=D&sntz=1&usg=AFQjCNHBP1DWJ-hytHl-QoHv1Gg4aG2ioA

That didn't help. Has anyone had success getting a dedicated GPU to run all aspects of the engine? My laptop is decent and I'd like to not have to buy a new one just because my onboard video card is causing an issue.

avatar image Matt.Williams Aug 17 '15 at 07:43 PM

Hi,

I'd like to ensure that you aren't making the Nvidia card the primary card for an old install of UDK (Unreal Engine 3 Development Kit). The program name for UE4 is UE4Editor.exe.

-Matt W.

avatar image ElChipacabra Aug 17 '15 at 08:55 PM

Hi Matt,

Thank you for taking a look at this.

I added UE4Editor.exe, along with pretty much every .exe that I could find within the C:\Program Files\Epic Games\4.8\Engine\Binaries\Win64 folder and set them to use the High-performance NVIDIA Processor. That didn't work, so I changed the Preferred Graphics Processor to use the NVIDIA card on the Global Settings tab. That didn't work either.

I don't know if this is related or not, but I see that the menus in the game are duplicating themselves in a quirky way. I can't remember when this started happening, but I think it may be related. I'm going try reinstalling UE4 tonight and see if that helps -- At least I can rule that out if nothing else.

alt text

error.png (344.9 kB)
avatar image Matt.Williams Aug 17 '15 at 09:12 PM

Can you also ensure your GPU drivers are up to date? And if it's using Nvidia Optimus, please make sure that's up to date. Also check your laptop manufacturers website for any additional driver updates that may be available.

-Matt W.

avatar image ElChipacabra Aug 18 '15 at 06:17 PM

My graphics drivers are all up to date, as is every other pertinent driver on my laptop. I've reinstalled UE4 and that I am still getting this video error whenever I'm working with large, 10+ fields data sources.

Do you have any other ideas as to things I could try?

avatar image ElChipacabra Aug 20 '15 at 03:44 AM

In answer to your question about Nvidia Optimus -- I'm fairly sure that I have that.

I found this post: https://answers.unrealengine.com/questions/19612/nvidia-optimus-always-using-intel-gpu.html# which didn't yield much help, more folks in my situation without a solution.

I don't have an option to set my video card within my bios, it's fairly basic as well. I've disabled Windows Aero to attempt to squeak out more video RAM. I've even disabled my second monitor to see if that worked. I've adjusted my Intel settings to provide maximum performance. I have no idea what else I can do here.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So I did some digging on the interwebs. It looks like Nvidia Optimus has trouble with 64bit software(most games are running 32bit) in Windows 7.

The solution has nothing to do with UE4 and we cannot take any responsibility for any issues that arise from attempting this fix. It is at your own risk.

That being said, it doesn't appear to be toooooo invasive. Check this out: https://forums.geforce.com/default/topic/748213/geforce-drivers/nvidia-optimus-big-problem-with-my-gtx660m/post/4292633/#4292633

-Matt W.

PS - All credit for inspiring this path of investigation goes to the very last post in that other AnswerHub thread by user FakeTruth

more ▼

answered Aug 20 '15 at 08:46 PM

avatar image Matt.Williams Aug 20 '15 at 09:20 PM

In case that link goes down, this is a quote from the post:


My solution - works without reboot (!): After a deep scan - i used sysinternals Tools to understand when optimus is being invoked, and why it cannot start to activate the right GFX choosen in the nvidia control Center. It is - as i thought - a really simple Problem in the registry. Each time an appliction starts, nvidia Needs to be triggered to start correctly. This is done by a registry entry : App_InitDlls Here you can tell Windows what Needs to be triggered when an app starts.

x32bit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows x64bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows

There you find the link to the NVINIT.DLL or NVINITx.DLL which lets nvidia invoking the right GFX. ...alright...

But under the reg key RequireSignedAppInit_DLLs the System requires a signed DLL to be invoked/triggered - the value of the key is 1 (true). After Setting this value to 0 (false) - my System runs perfectly!!

Solution: set the following keys to 0 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\RequireSignedAppInit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\RequireSignedAppInit

You do not Need to restart the System - you can test it directly!

It seems that Nvidea missed to sign These DLLs ... thats all.

avatar image ElChipacabra Aug 20 '15 at 10:03 PM

Hi Matt,

Thank you for sending that. I gave it a shot and I was having the same issue that several other users were; I didn't have the same folder that he mentioned in his post, but I found two keys that was named almost the same thing (LoadAppInit_DLLs) as what he mentioned along the same path. I disabled those and tried again in UE editor. I managed to get a crash log instead of the video card error. I re-enabled them for now, but would you like me to include the crash log to see if that's helpful?

Thanks again for the help,

Chip

avatar image Matt.Williams Aug 21 '15 at 01:28 PM

Could be helpful. Go ahead and throw the crash log into a txt file and attach it.

avatar image ElChipacabra Aug 21 '15 at 02:01 PM

I'm away from my laptop until Sunday night. I'll post it once I get back.

Thanks Matt.

avatar image ElChipacabra Aug 23 '15 at 09:30 PM

Matt -- As promised. Let me know if you need any more information.

link text

crash log.txt (9.0 kB)
avatar image Matt.Williams Aug 28 '15 at 03:10 PM

Can you try going back into regedit? Where you weren't able to find the RequireSignedAppInit files, can you right click and create a new DWord, then name it "RequiredSignedAppInit" and give it a value of 0.

With any luck that should work.

We cannot assume any responsibility for issues this could cause. This is a known issue with Nvidia Optimus and this is a user supplied workaround.

-Matt W.

avatar image ElChipacabra Aug 28 '15 at 03:59 PM

Hi Matt,

I added a new RequiredSignedAppInit registry key with a value of 0 into HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\

I'm still receiving the same error from my first post. I also tried changing LoadAppInit_DLLs to zero and still received the error. Thank you for offering the solution.

Chip

avatar image Matt.Williams Aug 28 '15 at 07:55 PM

Just making absolutely certain that you did it in both locations, not just the one.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\RequireSignedAppInit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\RequireSignedAppInit

I'm going to try to look into this more as we are making a GPU troubleshooting guide, but as it seems Nvidia related, I would also suggest posting to their support on this issue and see what they have to say.

avatar image ElChipacabra Aug 28 '15 at 09:05 PM

Correct, I added the registry key to both locations and still received the video memory error. Thanks for continuing to look at this, I'll see if I can get any support from NVidia.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question