x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] Android - Packaging fails because of too large integer?

Hi.

As in the title I´m trying to build a very small project for android (one extremely low poly mesh). When I launch it on my device it works, but when I try to package a shipping version, the process crashes with the error

inFrameActions: Packaging (Android (All)): -compile: MainFrameActions: Packaging (Android (All)): [javac] Compiling 68 source files to F:\UnrealProjects\ProjectName\Intermediate\Android\APK\bin\classes MainFrameActions: Packaging (Android (All)): [javac] F:\UnrealProjects\ProjectName\Intermediate\Android\APK\src\com\CompanyName\Alias\OBBData.java:20: error: integer number too large: 2789046397 MainFrameActions: Packaging (Android (All)): [javac] 2789046397 // the length of the file in bytes MainFrameActions: Packaging (Android (All)): [javac] ^ MainFrameActions: Packaging (Android (All)): [javac] 1 error MainFrameActions: Packaging (Android (All)): BUILD FAILED MainFrameActions: Packaging (Android (All)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:716: The following error occurred while executing this line: MainFrameActions: Packaging (Android (All)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:730: Compile failed; see the compiler error output for details. MainFrameActions: Packaging (Android (All)): Total time: 7 seconds MainFrameActions: Packaging (Android (All)): BuildCommand.Execute: ERROR: BUILD FAILED MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c "C:\NVPACK\apache-ant-1.8.2/bin/ant.bat" debug MainFrameActions: Packaging (Android (All)): Stacktrace: bei UnrealBuildTool.Android.UEDeployAndroid.RunCommandLineProgramAndThrowOnError(String WorkingDirectory, S MainFrameActions: Packaging (Android (All)): tring Command, String Params, String OverrideDesc, Boolean bUseShellExecute) MainFrameActions: Packaging (Android (All)): bei UnrealBuildTool.Android.UEDeployAndroid.MakeApk(String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPackagingDataInApk) MainFrameActions: Packaging (Android (All)): bei UnrealBuildTool.Android.UEDeployAndroid.PrepForUATPackageOrDeploy(String ProjectName, String ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy) MainFrameActions: Packaging (Android (All)): bei AndroidPlatform.Package(ProjectParams Params, DeploymentContext SC, Int32 WorkingCL) MainFrameActions: Packaging (Android (All)): bei Project.Package(ProjectParams Params, Int32 WorkingCL) MainFrameActions: Packaging (Android (All)): bei BuildCookRun.DoBuildCookRun(ProjectParams Params) MainFrameActions: Packaging (Android (All)): bei BuildCommand.Execute() MainFrameActions: Packaging (Android (All)): bei AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) MainFrameActions: Packaging (Android (All)): bei AutomationTool.Automation.Process(String[] CommandLine) MainFrameActions: Packaging (Android (All)): bei AutomationTool.Program.MainProc(Object Param) MainFrameActions: Packaging (Android (All)): bei AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param) MainFrameActions: Packaging (Android (All)): bei AutomationTool.Program.Main() MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: ERROR: cmd.exe failed with args /c "C:\NVPACK\apache-ant-1.8.2/bin/ant.bat" debug MainFrameActions: Packaging (Android (All)): ProcessManager.KillAll: Trying to kill 0 spawned processes. MainFrameActions: Packaging (Android (All)): Program.Main: AutomationTool exiting with ExitCode=1 MainFrameActions: Packaging (Android (All)): Domain_ProcessExit MainFrameActions: Packaging (Android (All)): ProcessManager.KillAll: Trying to kill 0 spawned processes. MainFrameActions: Packaging (Android (All)): copying UAT log files... MainFrameActions: Packaging (Android (All)): RunUAT.bat ERROR: AutomationTool was unable to run successfully. MainFrameActions: Packaging (Android (All)): BUILD FAILED

How is it even possible? I´m not even using big integers in my project. The highest number is 5. I tried to provide a keystore but same thing. I also tried different versions of the tegra sdk (or whatever it is clled) and am currently on the latest AndroidWorks.

EDIT: After trying to build a shipping version also the launch on device fails until I delete everything within the Build\Android directory.

EDIT2: I tried to do the exact same stuff with Unity, same assets, same functionality, same SDK versions. Works perfectly from scratch.

Any idea?

Product Version: UE 4.8
Tags:
more ▼

asked Aug 14 '15 at 04:58 PM in Packaging & Deployment

avatar image

Zodiarc
11 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Mar 24 '16 at 07:23 PM by Samantha Sutton for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks!


0 answers: sort voted first

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question