x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 stops working while importing

When i import a FBX file my Eu4 stops working. The file should be no problem, i tried it on a different pc and it worked. I am new to the program so i don't know much about it, i watched a few tutorials but i cannot figure out what the problem could be. Nobody else seems to have that problem.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 15 '15 at 11:32 AM in Using UE4

avatar image

Ozayyy
1 1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Ozayyy,

I guarantee you're not the only one that has run into this problem.

It may appear as if UE4 has stopped responding and it may even indicate this in the Task Manager if you hit Ctrl+Alt+Delete, but it's just processing the data from the FBX. The largely depends on a number of things with the FBX along with the system specs on how long it will take to import.

To give you the gist of what's going on. When you import a FBX that contains multiple pieces this can cause the editor to appear as if it's frozen (usually around the 50 or 75% points). This can largely depend on the number of pieces, the complexity of the pieces, and the size of the FBX as a whole. When using the option "combine meshes" in the FBX Import options the individual pieces of the mesh have to be loaded into memory and then saved to what will be the final combined mesh. This process can take a while, again, depending on mesh complexity and number of pieces.

You can quickly test if this is case by unchecking "combine meshes" and see if the mesh comes in a shorter time. This will indicate that it's just the serialization process of the mesh being written to memory and then saved for each piece that is what is slowing down the process.

I hope this helps.

Tim

more ▼

answered Aug 17 '15 at 06:44 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 879

avatar image Iridescence Aug 17 '15 at 07:09 PM

I will add that packing Textures and Materials Included in your .FBX format will greatly slow down your Import times.

avatar image Goramiir Jan 20 '16 at 12:38 AM

I am having the same issue. I have waited for over an hour and it is stuck at 96%. The mesh i'm importing in is a simple Combat Knife I modeled in blender. I have even tried to import it without textures, normals. I don't think it's being slow. It's stuck. I have also tried other models all the same get to 96% and lock up. I have tried to unistall and reinstall unreal, I need help.

avatar image Tim Hobson ♦♦ STAFF Jan 20 '16 at 10:56 AM

@Goramiir

Can you upload the asset here and I'll have a look at the FBX when I get some free time. Can you also post your DXDiag as well?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sometimes is caused when your imported object is too small. (well, it happened for me more than once) Check your object size in the DCC before exporting, or adjust the scale on importing.

more ▼

answered Jul 16 '18 at 05:29 PM

avatar image

schmigel
48 4 6 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Believe it or not, one of Windows 10 securty updates f**ked up every app on my end , one of that issues that I was unable to import any think by drag and drop inside unreal or unity, unreal always crash whenever i try to import an png file.

Sadly it fixed by clean install for windows cuz I already deleted the sytem restore by accident . check when it was working fine for you and try to make your system to restore to this moment if you still have the backup from windows update.

more ▼

answered Jul 17 '18 at 11:08 AM

avatar image

Omar Vector
445 16 16 29

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question