x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Float UMaterial Parameter throws error in matinee when Exporting Movie

I'm using some float material Parameter tracks in matinee to control some materials. When Trying to render the clip out through clicking 'Movie' I get the following error:

 Can't save /../ Nebula__sovereign_fires_back.umap: Graph is linked to private object(s) in an external package.
 External Object(s):
 InterpTrackFloatMaterialParam_1
 InterpGroup_5
 InterpTrackFloatMaterialParam_3
 InterpGroup_7

  

Deleting the tracks (I have two in the project) with the float U material Parameters will allow the render to continue.

TO REPRODUCE:

-Create a material with a scalar paramater.

-In Matinee: New group (I've got the Decal actor selected when creating a new group) > Add Float Material Parameter Track.

-Try and Export a movie.

Thanks in advance for any suggestions. Please let me know if you need any more information.

-Luke.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 15 '15 at 08:10 PM in Bug Reports

avatar image

Lukewade2
1 2 4

avatar image Lovecraft_K ♦♦ STAFF Aug 17 '15 at 06:51 PM

Hi -

Following your reproduction steps I am not getting any error messages. I have attached my Test Project below, can you have a look and make adjustments to make it closer to your project?

Thank You -

Eric Ketchum

Test_Project_4.8.3

test_project.zip (484.2 kB)
avatar image Lukewade2 Aug 17 '15 at 10:36 PM

Hi Eric, Unfortunately (or fortunately) I cannot reproduce the error also.

In the project I initially created the Matinees by right clicking in the content browser and creating a matinee sequence there, before dragging it into my level and animating. I could not export the result. Deleting the Umaterial Paramater tracks allowed me to export.

In the same project I went ahed and created a matinee (By using the top toolbar, not the content browser) and everything worked fine. (I copied the animation data to the new matinee, Material Paramaters and all)

I've tried a couple things now and cannot bring up the error in any other project. The error is still showing in the original level however.

I've migrated a version of the scene and attached it. If there's anything else I can help with please let me know.

https://drive.google.com/file/d/0Bw-Uc-WTBNQ5SklnTnowSXMwU00/view?usp=sharing

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Lukewade2 -

Thank you for your test project that helped me narrow down the issue. I was able to reproduce it now and have entered a bug report as UE-20123. I will keep you informed here as we investigate a solution to this issue, though it might come back as designed. In the meantime, I would recommend keeping the created InterpData File that gets created when you add a Matinee Actor from the Viewport Matinee dropdown.

Thank You Again for your help -

Eric Ketchum

more ▼

answered Aug 18 '15 at 08:10 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question