x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture preview and ingame, on sphere primitive mesh is different

Preview mesh sphere primitive shows a perfect earth with my earth texture. Just as I would wish it appear in the game.

However ingame it does not appear like in the preview, the texture looks not stretched properly.

I want to make a planet and a drag and drop does not work. It shows perfectly though in the preview window, but not on the sphere mesh in game. Why?

Product Version: Not Selected
Tags:
more ▼

asked Apr 11 '14 at 02:57 PM in Using UE4

avatar image

maker
6 1 2 2

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

The sphere mesh you're using in the game appears to have different UV coordinates. The mesh used in the material editor is /Engine/EditorMeshes/EditorSphere, so try using that one instead.

more ▼

answered Apr 11 '14 at 04:35 PM

avatar image

BJ
76 2 2 2

avatar image maker Apr 11 '14 at 04:54 PM

First I cant find the editorsphere anywhere. Secondly, even if I change the preview mesh to Shape_Sphere.

Delete that. Thanks alot BJ!

I found another sphere shape called Shape_Sphere, which seems to be the editor sphere aswell!

Wow that took a while! Is it even possible to learn this engine? The earth looks great now!

(comments are locked)
10|2000 characters needed characters left

LOD settings i guess. Try disabling streaming on your earth texture.

more ▼

answered Apr 11 '14 at 02:59 PM

avatar image

BiggestSmile
1.6k 53 38 105

avatar image maker Apr 11 '14 at 04:17 PM

http://sv.tinypic.com/r/k398r4/8 http://sv.tinypic.com/r/2cbtz9/8 this is what it looks like

Where are the lod settings exactly, and how to disable streaming on a texture?

It says when I build that Material Sphere has overlapping UVs

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question