x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I point Unreal to the Perforce folder without creating a new project?

Setting up Perforce, I've successfully connected via P4Admin and P4V. I initially specified my Unreal folder in MyDocs as the Perforce workspace but it was having issues. I then created a new folder off my SSD for the Perforce connection. From there, I created a new Unreal Project and saved it in that location and was successful in synching those files to Perforce. The issue comes when I have other users connect; they're able to connect and download the Unreal Project files I uploaded, but, when they open the .uproject file that launches unreal and attempt to connect to Perforce via the 'Connect to Source Control' option in the content browser, no workspace is available for them to choose, Is this a server side or client side workspace it is referring to?

Product Version: Not Selected
Tags:
more ▼

asked Apr 11 '14 at 03:29 PM in Everything Else

avatar image

ohmk
6 4 7 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

The Perforce workspace is what maps the server-side depot files into a directory tree on your local machine. There are a few reasons why workspaces may not be available to choose from the login dialog's dropdown:

  • The workspace does not map to the projects root directory.

  • The workspace is not set up to be used with the clients host machine.

There are other potential issues too, related to how you have set up your source control server:

  • Do you have a locally-hosted server or is it remote, perhaps hosted by an external provider, like Assembla?

  • Is your server SSL or stream-enabled (neither of these features are supported by the current version, 4.0).

Finally, taking a look at your logs (stored in /Saved/Logs) can reveal potential problems with Perforce connections. If you continue to get issues please post a log from a connection attempt here and I'll try to help.

more ▼

answered Apr 11 '14 at 03:40 PM

avatar image

Tom Sarkanen STAFF
1.7k 39 12 53

avatar image ohmk Apr 11 '14 at 03:56 PM

Regarding the last two points, the server is hosted via Digital Ocean and is not in the streamsDepot but in the normal depot.

When I have users create a perforce workspace client-side, do they have to name it the same way I did when it was setup?

avatar image ohmk Apr 11 '14 at 06:24 PM

Regarding the first two points, could you provide what settings I should specify for perforce on a linux server to fix those? Does the workspace have to be in the same location for all other PC's (for example C:\UnrealProject)?

avatar image Tom Sarkanen STAFF Apr 14 '14 at 09:24 AM

Can you post a log so we can verify whether this is actually an issue with workspace mappings first?

Please start up the editor, bring up the source control login dialog & click the workspaces drop-down, then shut the editor down & post the resulting log (located as above) here.

avatar image ohmk Apr 14 '14 at 05:31 PM

Tom, thank you for your persistence in helping me gauge this issue. I'm not entirely sure what fixed it, but when I went through the P4V install 1 on 1 with my users, it worked perfectly. I believe the issue may have somehow been based around the fact that they never setup a custom location or workspace name, so default values were applied. This worked fine through P4V and getting our depot, but it never would populate the dropdown in UE4. After deleting that workspace and creating a new with a custom name, all works perfectly. Thank you sir.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question