x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Distance Field Shadows not working with directional lights

Ray traced distance field shadows works perfectly using point lights but as soon as i am using directional lights i am getting no shadows at all unless i use the other techniques, i do not know what i am doing wrong and i have searched the forums and used google but nothing comes up regarding this issue.

alt text

Product Version: UE 4.8
Tags:
more ▼

asked Aug 17 '15 at 06:37 AM in Rendering

avatar image

Elias79
21 3 8 8

avatar image david376 Aug 17 '15 at 09:55 AM

I had the same problem before.But suddenly it works,I don't know why.

avatar image Logan Bailey ♦♦ STAFF Aug 17 '15 at 07:03 PM

Hello Elias79,

So to clarify these are the steps you are using to enable Ray Traced Distance Field?

  1. Go to your project settings > Render > Enable Mesh Distance Fields

  2. Restart your project after saving.

  3. Go to your directional light and enable ray Traced Distance Field Shadows

alt text

Following these steps I was able to create the image above.

Let me know if you are doing any additional steps,

Thanks,

Logan

avatar image Elias79 Aug 18 '15 at 12:08 AM

I have now tried using a new project one time using the empty level and first then with the default preset, same result with no shadows if i disable dynamic shadows by putting the distance to 0 and enable distance fields still nothing could be a limitation with my graphics drivers if so why does it work with point lights it cant only affect directional lights right if it was a drivers issue I am using Unreal Engine 4.8 and running on Amd radeon 280x if that gives you any info, as directional is the only thing that DFS do not work with i don't know what to tell you, anyone else that had these problems?

And should i try with a older version of unreal editor if possible on another computer maybe?

sigh

avatar image bdurar Aug 18 '15 at 07:00 AM

I'm having the same problem. Followed all the steps. Ray Traced shadows are working perfectly with a Point Light, but not with a Directional Light.

I've tried about everything I can think of. RayTraced DistanceField Shadows is ticked on my Directional Light and all settings seem to be correct...

Not sure if it matters, but I also have an AMD card (radeon 7850)

avatar image Elias79 Aug 18 '15 at 10:39 AM

Well it is either a amd gpu drivers issue or a problem with the new Unreal Engine 4.8 so i hope someone could find a solution soon.

avatar image Elias79 Aug 23 '15 at 11:46 AM

Sadly same problem in Unreal Enigne 4.9 preview.

avatar image Sarr Aug 23 '15 at 08:34 PM

Experiencing same issues with both 4.8.3 and 4.9 preview, works fine with point lights, but not with directional lights.

avatar image Elias79 Aug 24 '15 at 08:14 AM

Thank you, now how do we report this bug to epic?

avatar image Sarr Aug 24 '15 at 11:20 AM

I assume someone (from epic) will see it, Also I discovered that at certain camera angles the shadows seem to appear and flash like crazy, and at other angles they seem to work normally. This did not happen in 4.7 , in 4.7 this worked flawlessly.

avatar image Logan Bailey ♦♦ STAFF Aug 24 '15 at 01:06 PM

Hello Elias79,

I apologize for the delay in the response,

If you would link me your DxDiag, then perhaps I can narrow down your issue.

Thanks,

Logan

avatar image Sarr Aug 24 '15 at 03:36 PM
dxdiag.txt (71.4 kB)
avatar image Logan Bailey ♦♦ STAFF Aug 24 '15 at 06:55 PM

HI Sarr,

Thanks for replying, however I was addressing Elias79 in regards to his question.

In response to both of your issues, with only Ellias79's screenshots, do either of you have your Engine Scalability settings set to Low.

If this is not set at medium or above then the shadows will not show up.

Logan

avatar image Sarr Aug 24 '15 at 08:25 PM

I figured since we both have exactly same issue that my dxdiag may have been helpful too, also someone here mentioned they think it may be AMD drivers, I have a friend with Nvidia card and he experiences same issues in 4.8 and 4.9 but shadows work for him in 4.7 just fine. I have scalability on Epic

avatar image Elias79 Aug 24 '15 at 09:12 PM

Thank you for your reply and here are my results.

alt text

alt text

http://pastebin.com/vSM7y8ey

avatar image Logan Bailey ♦♦ STAFF Aug 24 '15 at 09:45 PM

Hey guys,

Not a problem,

Here is what I would like for you two to do.

  1. Create a new Project

  2. Delete the sky light and skysphere from your project so that the only light in the scene is the directional light.

  3. Delete the direction light that is called light source.

  4. Create a new directional light in your project

  5. If you directional is static or stationary then you will need to rebuild your light maps by clicking build in the main viewport.

There a few possibilities for what could be happening,

  1. Your lightmaps have not been rebuilt therefore causing the shadows not to be calculated in a render pass.

  2. There is a kind of issue with the skylight and skysphere overriding the shadows of your directional light.

I will continue to do more research on my end as you are recreating these steps

Thanks,

Logan

avatar image Sarr Aug 24 '15 at 10:11 PM

In my main project my directional light is dynamic, and I've tried removing every other light, and even the skysphere and rebuilded the lightmaps, still the same issue,

in a new project, removed all lights and the skysphere, added dynamic directional light, set GenerateMeshDistanceFields, restarted editor, rebuild lightmaps. still no raytraced shadow, I can visualize the Mesh Distance Fields and see them.

avatar image Elias79 Aug 24 '15 at 10:25 PM

Yea same problems here i tried these steps and before this i used the Distance field test file provided by Tim Hobson.

https://answers.unrealengine.com/storage/temp/55572-df_test.zip

I have yet to try using unreal engine 4.7 as im out of space on my system disk drive so im wondering if can i install unreal engine 4.7 on another hard drive?

(comments are locked)
10|2000 characters needed characters left

6 answers: sort voted first

Hey guys,

I apologize for the delay in answer. Another support team member found that this is indeed a bug.

It appears to be an issue with that particular series of Radeon graphics cards.

In the meantime a possible work around is to use a point light for specific shadowing that fits your project needs.

This issue is currently being looked into by our development team. The bug number is UE-20358

Thank you both for reporting this issue,

Logan

more ▼

answered Aug 25 '15 at 05:47 PM

avatar image sbnewsom Sep 13 '15 at 11:24 PM

I'm having this problem on my Nvidia GTX 960. Its not a Radeon problem. It seems I've had this problem for the last version too.

(comments are locked)
10|2000 characters needed characters left

I'm having the same issue on a GTX660M

more ▼

answered Sep 04 '15 at 11:49 AM

avatar image

Fantasifall
234 5 7 15

(comments are locked)
10|2000 characters needed characters left

Similar problem in 4.8 - 4.9.1.

dxdiag.txt (28.6 kB)
more ▼

answered Sep 16 '15 at 11:16 AM

avatar image

Elkyspeed
1 1

(comments are locked)
10|2000 characters needed characters left

Hello All,

Thank you all for reporting the similar issues. However, If you would like to open your own threads and report them there, then it will be easier to track. This thread is already becoming lengthy and other users experiencing this issue will need to scroll down quite far to see that I have already reported this issue and it is being looked into.

Please look forward to updates on this issues progress.

Again this issue has already been reported. If you are experiencing a similar issue than please report it separately on your specific issue.

Thank you,

Logan

more ▼

answered Sep 16 '15 at 01:17 PM

(comments are locked)
10|2000 characters needed characters left

I had the same issue, downloading the chipset drivers solved it,
Now keep in mind, AMD autodetect driver utility does NOT install the chipset drivers, you need to go to the site and select your gpu version and under optional downloads section, download the chipset drivers(around 40mb). Hope this solves your problems too.

more ▼

answered Dec 10 '15 at 12:12 PM

avatar image

SongOfDeath
82 18 24 32

avatar image Efrye Dec 10 '15 at 05:39 PM

Thanks for sharing this information, but unfortunately it didn't change anything on my end. I'm using a Radeon R9 270X and even after manually installing the latest chipset drivers, I still don't get distance field shadows on directional lights. Spot lights and point lights are working fine.

avatar image SongOfDeath Dec 10 '15 at 06:09 PM

Can you try this: Change light type to stationary and change the source angle on the light by using the slider(not typing in the number), do the distance field shadows appear after doing that?
Or) Right click somewhere in the viewport,(bring up the menu that says place actor and stuff), realtime should stop after the right click, do the shadows appear while the menu is there?

avatar image Efrye Dec 11 '15 at 10:03 AM

Thanks again for your help. Unfortunately neither of your suggestions fixed the problem. I tried it in a new project as well to make sure it's not caused by something in my current project, but that didn't work either. I'll try testing it on a different PC to make sure it's actually a problem with the GPU and not a mistake on my part.

avatar image SongOfDeath Dec 12 '15 at 07:49 AM

Yeah I got it working but not completely, distance field shadows are working but if I set the game to fullscreen mode 0, it drops fps from 90 to 30 while moving, when I turn distance f. shadows off it doesn't drop fps. On windowed mode they work fine, I upgraded project to 4.10, I'll also upgrade to windows 10, if those don't work I got nvidia card I'll try with that.

(comments are locked)
10|2000 characters needed characters left

Hi guess, I guess my response is a little late and I am not sure if you guys are still there, I had the same problem today, then I figured it out. You have to go to Setting--- scalability settings, change it to epic and it solves the problem. Hopefully it helps.

more ▼

answered Jun 20 '16 at 02:36 AM

avatar image

kenshin314
1

avatar image Sarr Jun 20 '16 at 02:32 PM

That did not help at all... Also In my case update to 4.11 helped thou not all objects are casting ray traced shadows.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question