x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Any way to fix UI lag in Editor?

Just wondered if there were any known solutions/causes of UI lag while using the editor. When I move my mouse around editor widgets there's a short delay between where the UI thinks my mouse is and where the cursor actually is. It appears to compound the more I interact with a widget/window, such as while browsing the right click menu in the content browser and various settings menus. It never gets unusably slow but it's tricky to follow where my cursor actually is.

Here's a video of the issue in the UE 4.9 preview, though I have the same issue with 4.8. In the video the delay isn't so pronounced, but there are often times where the delay is significantly longer.

When I searched answerhub I found somebody who had a similar issue and fixed it by disabling an on-screen display that came with their graphics card driver. Are there any other applications that may cause this issue?

OS: Windows 10 CPU: i7-6700k RAM: 32gb GPU: evga gtx 680

Product Version: UE 4.9 Preview
Tags:
more ▼

asked Aug 18 '15 at 11:46 AM in Using UE4

avatar image

MrBushido
61 6 8 94

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first

Taking a note from the post that was solved by disabling EVGA precision, went through all the applications and background services on my system to try and figure out the cause. In my case it appears that the "Sonic Studio 2" application that came with my motherboards onboard sound driver is the cause of this issue.

I solved this issue by disabling it in the Start-Up section of the task manager:

TaskManagerScreenshot

For reference of it's impact on editor performance here is a video showing performance when it is disabled:

https://youtu.be/-p_1S352JoY

And a video with it enabled:

https://youtu.be/UDWi5kNuKnI

more ▼

answered Aug 23 '15 at 09:04 AM

avatar image

MrBushido
61 6 8 94

avatar image BotOnQuest Dec 28 '15 at 06:34 AM

Super Thanks! I was getting so annoyed for this issue. It was effecting other software like Unity 3d and 3D Max.

avatar image MNP_David Apr 04 '16 at 09:46 PM

Wow thanks for the help! This still breaks UE4 even months later.

avatar image MrBushido Apr 04 '16 at 09:58 PM

Probably something that Epic cannot fix. Tried contact ASUS about but SonarSuite but judging by the lack of updates we've been brushed off!

avatar image -Mew Jul 02 '16 at 07:03 AM

Finally an answer to my problem... Thank you.

avatar image fruel Jul 15 '16 at 07:40 PM

UE 4.12.5 on pretty much the same hardware. Exactly the same issue. Additional info: Killing the SonarSuite processes alone does not help. You really have to disable autostart and reboot.

avatar image agov06 Dec 05 '16 at 09:09 PM

Wow this was really annoying to find. But actually really interesting that it can disable GPU acceleration in a different application

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

FYI, I am using MSI motherboard and the sound program called Nahimic is also causing the same slow down issue too

more ▼

answered Sep 05 '16 at 11:38 PM

avatar image

nachilau
105 9 12 26

avatar image RedSkyJedi Dec 09 '16 at 04:22 AM

Thank you for this! I've been searching frantically for a solution and this did it for me.

avatar image TehRick Dec 16 '18 at 04:21 PM

Thanks, Nahimic was kinda slowing down everything, it also causes freezes when playing videos in navigators..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

FYI, I got gtx 980 installed and recently the editor becomes very lagging. I just upgraded my nvidia driver to the most recent version, and the lagging issue is now solved.

more ▼

answered Mar 06 '17 at 09:28 AM

avatar image

wcl1993
111 32 23 37

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just to add on to this.. I traditionally booted up the editor from Visual Studio using the local windows debugger option, which seems to have been the cause of some severe slowdown.

After switching to just launching the editor via the Uproject / Epic Games Launcher things started running a lot smoother without anywhere near as much slowdown when interacting with the menus. Seems there's quite a performance hit when running with the debugger / VS attached.

more ▼

answered Mar 01 '18 at 06:42 PM

avatar image

RichardWilliams
21 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For those who could not solve the problem with the above solution. Disable ShadowPlay on GeForce Experience!

more ▼

answered Mar 01 '18 at 06:37 PM

avatar image

DevCorp Studios
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For those who could not solve the problem with the above solution. Disable ShadowPlay on GeForce Experience!

more ▼

answered Mar 01 '18 at 06:37 PM

avatar image

DevCorp Studios
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question