x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Move To" not moving my AI Character to target location.

Hello all. I've spent quite a bit of time here on the forums looking for some assistance and generally I have found what I have needed (thanks for that!). Alas, I seem to be stuck now and have bit the bullet to ask for some help.

I have been following Newton's AI Behaviour and NavMesh tutorial steadily but my AI bot is stubbornly standing still. I have my suspicions of where the problem may be so please bear with me as I try and illustrate my own troubleshooting progress.

To illustrate my problem, here is a screen shot of my BotAITree as it get stucks on the "Move To" instruction:

alt text

As you can see, it does hit the "Move To" command but it doesn't have any effect. The update Route also fires, incrementing through the waypoint indices. It then obviously starts again through setting walk speed, finding the route and then attempting a "Move To" again.

I suspect the issue may be caused by UpdateRoute, where I had to override the PerformConditionCheckAI function. Here is a screenshot of my attempt (noting the checked return value):

alt text

Here is the event graph of my UpdateRoute. Notice that that I have not connected the node result to the connection. If I do, the return value is never true and so the Move To command is never executed. To get it working, I set the value to succeeded:

alt text

Otherwise, I'm fairly sure the rest of my blueprints are correct. I've tried to debug with breakpoints and I'm stuck on the Move To. I would appreciate any help you could offer, as I'm sure there is a little something silly that I've missed (speaking of which, I have check that I have a NavMesh and my target waypoints are in the map). Thanks!

Product Version: UE 4.8
Tags:
screenshot 1.png (326.4 kB)
screenshot 2.png (129.5 kB)
screenshot 3.png (226.3 kB)
more ▼

asked Aug 19 '15 at 12:09 AM in Blueprint Scripting

avatar image

Gazumpster
26 1 3 51

avatar image Gazumpster Aug 19 '15 at 12:12 AM

It is 1:11AM at the moment, so I'm going to get some rest and check the answers in the morning (just in case anyone expects a quick reply).

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I'm embarrassed to admit that I've woken up this morning and solved the problem. So, it turns out that the placement of the waypoints is extremely important for the bot's navigation. I had them placed above the ground by perhaps 30 or 40 units but still within the navmesh bound box. All I did was move the waypoints down in Z value and now the bot has sprung to life.

I've seen plenty of people on here run into this problem and attempt extremely complicated fixes. Try moving your waypoints down first... just in case :)

more ▼

answered Aug 19 '15 at 07:57 AM

avatar image

Gazumpster
26 1 3 51

avatar image mtrebi May 02 '16 at 07:25 PM

You can always use the Project Point to Navigation to be sure the point is in the navmesh.

avatar image voidnullptr Mar 13 '17 at 01:31 AM

Dude you saved me, I was wondering the same thing, lowered the target points and done!, thanks a lot.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question