x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Imported models react to lighting VERY erratically, seems project specific.

alt text

Been working a project for a while, didn't create it, setup some scenes in another project I created and brought them in: Started noticing lighting was off.

In this image, a spotlight is directly above the three cubes, only the cube from the content library lights correctly. The others, imported from 3DS 2015 with recommended settings, using both FBX 2013 and FBX 2014, render like a crazy person. Light on the top is only received from half the spotlight (or point light), and the axis seems linked to the axis alignment in the UVW map modifier in 3DS. In other words, the whole surface will be lit if I moved the light toward the lower left corner in this image, once both the cube was fully in the hemisphere it decided to respond to.

Beyond the intended surfaces lighting incorrectly, light also appears on faces that shouldn't receive light at all, not pictured: There is light on the bottom of the two left cubes in a pattern that essentially mirrors the top.

If I make a new project and bring them in, they're fine. It seems to be this project only. So my question is: Is this a bug/corrupted project, or is there some project level setting that might have caused this?

More details: Tried importing normals/tangents, generating on import, manually triangulating the mesh, triangulating on export, tried baked and dynamic lighting, let Unreal generate light maps; all produce essentially these results.

Also of note: The problem project shows up as compatible with "Unreal Engine Other"

Product Version: UE 4.8
Tags:
lightingerror.jpg (89.5 kB)
more ▼

asked Aug 20 '15 at 02:37 PM in Bug Reports

avatar image

efosGD
16 1 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey efosGD,

If the problem is occurring solely in this specific project, it could be the project and contents within have been corrupted. This can happen when you migrate content that is tied specifically to a project and its engine version. You mentioned you had been working on a project for a while, which I can assume you upgraded the engine version at least once?

If you used the 'Convert-in-Place' option instead of the 'Open a Copy' option when upgrading your project's engine version, this could be the culprit. I always suggest opening a copy instead of converting in place for compatibility reasons. This will ensure your original project does not get corrupted in the upgrading process.

Unless I can reproduce this issue on my end, which seems unlikely, this is a project specific issue. Moving forward, try to be careful about migrating assets between engine versions and projects. Always take the safer route and create a copy before taking any actions.

Thank you,

Andrew Hurley

more ▼

answered Aug 20 '15 at 05:30 PM

avatar image efosGD Aug 20 '15 at 07:08 PM

While it did affect the migrated assets, I was able to reproduce the errors by creating a new asset in the bad project. (Assets in the picture are new)

The bad project was 'conterted in place' at some point. Will avoid this in the future, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question