x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.8.3] Overwritting fbx with combined mesh off won't save

I have an fbx that contains 160 meshes. I don't want to have to export 160 meshes individually in order to import them into unreal.

So, I am exporting them as a single fbx (modo) and then importing them into unreal with "Combine Meshes" unchecked.

alt text

This imports all 160 of the meshes as separate static meshes and works fine the first time. I am then placing these meshes in their correct locations.

And then I make changes to some of the meshes in modo and re-import the fbx into unreal. It imports and appears to overwrite the meshes correctly.

However, when I try and save my unreal map it gives me the following error for all of the meshes that were overwritten.

"ModelName.uasset cannot be saved as it has only been partially loaded"

If I first delete all of the models and then do the import I don't get this error on save.

However, I don't want to have to delete all of 160 models each time and have to re-position them. That is insanity.

Product Version: UE 4.8
Tags:
fbx_import.png (66.0 kB)
more ▼

asked Aug 20 '15 at 03:53 PM in Bug Reports

avatar image

erebel55
385 43 46 66

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Erebel55,

I have tried reproducing this in 4.8.3 and our 4.9 preview 4 and I'm not having any luck.

Here are the steps I'm using.

  • Make several objects in 3Ds Max (using basic shapes only)

  • Export as single FBX file

  • Open Blank Project in Unreal Engine 4.

  • Import FBX file (Combine Meshes unchecked)

  • place objects in the scene

  • Save all and name my map.

  • Go back to 3Ds max and alter my meshes

  • Re-export and overwrite original FBX file with changes

  • In UE4, select IMPORT and overwrite all other meshes imported with this file.

  • Can visually see change in the viewport of the editor.

  • Save all.

Using these steps, everything is working on my end that I can see. Did I miss something or do something differently than you?

Thank you!

Tim

more ▼

answered Aug 21 '15 at 06:38 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question