x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rama's Victory Plugin

alt text

Been trying for most the day to install Rama's Victory Plugin in 4.8 c++ project. Can't get past the rebuild errors. Tried a combination of all below. Pretty sure these are all in the right locations and considering I've generated longer xcode error reports than the great wall I'm out of ideas.

1) Plugin is in the "Plugins" folder

2) Updated [Plugins] in the DefaultEngine.ini

3) Added to Project.Build.cs: PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "VictoryBPLibrary", "UMG", "Slate", "SlateCore" ,"AIModule"});

4) Project.uproject: { "Name": "VictoryBPLibrary" "Enabled": true },

5) At the moment it's reporting:

 Discovering modules, targets and source code for game...
 Errors detected while compiling /Users/TJ/Documents/Unreal Projects/DVISION_GIG/Intermediate/Build/BuildRules/ProjectFileGeneratorModuleRules.dll:
 /Users/TJ/Documents/Unreal Projects/DVISION_GIG/Source/DVISION_GIG/DVISION_GIG.Build.cs(13,32) : error CS1061: Type `System.Collections.Generic.List<string>' does not contain a definition for `AddRanges' and no extension method `AddRanges' of type `System.Collections.Generic.List<string>' could be found. Are you missing an assembly reference?
 (0,0) : error : /Users/Shared/UnrealEngine/4.8/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mscorlib.dll (Location of the symbol related to previous error)
 UnrealBuildTool Exception: ERROR: UnrealBuildTool encountered an error while compiling source files
 TJs-iMac:Mac TJ$  logout

[Process completed]

Anything obvious that you guys think I may have missed?

Product Version: UE 4.8
Tags:
more ▼

asked Aug 21 '15 at 06:01 AM in C++ Programming

avatar image

tjbechard
1 2 5 4

avatar image Rama Aug 21 '15 at 04:15 PM

Looks like you have an error in your build cs?

 "`System.Collections.Generic.List<string>' does not contain a definition for `AddRanges' and no extension method `AddRanges' of type `System.Collections.Generic.List<string>' could be found."

Can you post your entire build cs for your main project and also what you have for the plugin's build cs?

It appears to be in your build cs tho:

 Documents/Unreal Projects/DVISION_GIG/Source/DVISION_GIG/DVISION_GIG.Build.cs(13,32) : error CS1061:

Have fun today!

:)

Rama

avatar image tjbechard Aug 22 '15 at 06:38 PM

Found the issue! Was VaRest for some reason. Removed all of its referencing files and had no problem compiling! I put Victory into my Plugins folder and still no luck on it showing up in editor under plugins. Made sure there's no referencing files to it also. Might name my first kid after you if this works...

 Last login: Sat Aug 22 11:27:15 on ttys001
 cd "/Users/Shared/UnrealEngine/4.8/Engine/Build/BatchFiles/Mac" 
  sh "/Users/Shared/UnrealEngine/4.8/Engine/Build/BatchFiles/Mac/RocketGenerateProjectFiles.sh" -project="/Users/TJ/Documents/Unreal Projects/DVISION_GIG/DVISION_GIG.uproject" -game
  logout
 
 TJs-iMac:~ TJ$ cd "/Users/Shared/UnrealEngine/4.8/Engine/Build/BatchFiles/Mac" 
 TJs-iMac:Mac TJ$  sh "/Users/Shared/UnrealEngine/4.8/Engine/Build/BatchFiles/Mac/RocketGenerateProjectFiles.sh" -project="/Users/TJ/Documents/Unreal Projects/DVISION_GIG/DVISION_GIG.uproject" -game
 
 Setting up Unreal Engine 4 project files...
 
 Setting up Mono
 
 Discovering modules, targets and source code for game...
 Generating data for project indexing... 100%
 Generating project file...
 Found 9 targets!
 Skipping project file write, as it didn't change...
 TJs-iMac:Mac TJ$  logout
 
 
 [Process completed]

avatar image tjbechard Aug 22 '15 at 06:57 PM

Almost built... alt text

... and failed >_< Looks like it's trying to overwrite some existing functions. Spent the last two days trying to get this to work :/

avatar image cancel Aug 22 '15 at 09:52 PM

These are actually warnings generated by the C++ compiler that are promoted into errors (thus stopping compilation) by the compilation flags passed by the Unreal Build Tool. The Clang compiler used by XCode detects more errors and is more strict about letting mistakes pass through than MSVC (the C++ compiler used by Visual Studio in Windows). It's likely that Rama develops on Windows and was unaware of these warnings generated by Clang.

You will need to ask Rama to fix the problems with his C++ code, or fix them yourself. Alternatively, you could find a way to disable -Werror in the build options generated by UBT, but I don't know how to do that. The errors don't look severe (in your screenshot, for example, it's a common duplicate variable naming mistake) so you should be able to fix them if you know some basic C++.

avatar image tjbechard Aug 24 '15 at 03:04 AM

Thanks for the enlightenment cancel! I'll look into UBT and see if I can find a work around.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question