x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Apex not working on multiple materials since 4.8

Hi, we have had APEX working before updating to 4.8, but afterwards we are getting an issue with skeletal meshes that have multiple materials. We have even reimported the same mesh and it has this problem though the source asset is exactly the same as what worked in 4.7.

alt text

alt text

The issue is essentially that any meshes with multiple materials applied will only render the first material ID (submesh 0)

Any other materials will not appear. This happens on our simple test case shown above, as well as the asset we discovered this issue (a cloak)

I have looked for solutions but cant find anything about it recently.

Product Version: UE 4.10
Tags:
maxview.jpg (581.5 kB)
ue4view.jpg (263.9 kB)
more ▼

asked Aug 21 '15 at 07:06 PM in Using UE4

avatar image

DylanBrady
71 7 12 18

avatar image RVillani Sep 25 '15 at 09:58 PM

I've bumped into this problem today. I need to have a transparent peace of cloth collide with an opaque one. So, I need to do a single mesh, but with two shaders. And it happens the same that's happening to you.

Epic, has this been fixed in 4.9? I can't test yet because of a plugin that's only working on 4.8 so far.

avatar image RVillani Sep 30 '15 at 01:34 AM

The plugin was updated for 4.9 and I tested the multi-material cloth. Still not working.

avatar image DylanBrady Oct 15 '15 at 10:26 PM

Ive now tried setting up cloth in maya 2014, and 2012, max 2014, aswell as setting up cloth in the proprietary clothing tool nvidia puts out. it all has the same result. every material ID becides the first one doesnt render ingame.

Can we get anyone to look at this? I can upload my test asset if that helps.

avatar image DylanBrady Oct 18 '15 at 11:30 PM

Ok sorry to keep bumping this but I have created a simple test asset that is giving me twofold issues. here is a picutre. https://www.dropbox.com/s/wi3yctvswj4kit6/image.JPG?dl=0

Could someone try importing these assets on their end and setting up cloth on it? heres is a dropbox link https://www.dropbox.com/s/bh9coandodk416q/Apex_Test.rar?dl=0

Edit: as you will note in that picture theres also some stretched vertices that seem to be related to this issue https://answers.unrealengine.com/questions/298645/apex-cloth-from-maya-turns-into-a-stretched-cone-d.html the person in that situation fixed the problem by using maya 2012 however as I said that didnt affect my issue.

avatar image DylanBrady Oct 26 '15 at 03:10 PM

https://answers.unrealengine.com/questions/25131/multiple-materials-on-apex-destructible-mesh.html Found this issue where the answer seems to be that its a known bug and is being worked on?

avatar image DylanBrady Nov 12 '15 at 03:49 PM

updating to say I tried out two of my old test assets and made a new one to test in 4.10 and had the exact same result. so This isn't addressed yet

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Dylan,

Sorry this one seems to have been overlooked apparently. If you ever find yourself with something like this where it worked in a specific version and then didn't in the next, this would be considered a regression unless there was a specific change that was meant to do that, which is usually detailed in the release notes. In that event, make sure to post it in the bug reports section of AnswerHub and we can make sure a tech is assigned to verify and submit a ticket.

I was able to reproduce this and confirm that it was working in 4.7. I have submitted UE-23300 for this to be investigated.

Once there is an update to the ticket and any relevant information to pass along I'll post back here.

Thank you!

Tim

more ▼

answered Nov 12 '15 at 11:20 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image Kartiks Nov 24 '15 at 08:27 PM

Hi Tim. We have verified the change that broke APEX for us is CL 2493547.

There is some discussion about the change here https://answers.unrealengine.com/questions/174392/apex-cloth-crash-on-set-clothing-selection.html We don't get the crash mentioned in that thread so we reverted 2493547. We are on 4.9.2

avatar image RVillani Nov 24 '15 at 08:31 PM

Will this reversion be on 4.10.1? I'm on a project full of workarounds because of this bug. I'd really appreciate to have it solved on the next hotfix.

Thanks, Kartiks!

avatar image Tim Hobson ♦♦ STAFF Nov 24 '15 at 09:28 PM

It's very timely that you posted.

I just finished syncing the build that has this fixed. However, I cannot guarantee this will be pushed out in any HotFixes. That is left up to the developers who integrated the change and how significant a change it is. Some changes cannot be merged as a hotfix unfortunately.

At the moment, my best guess would be that it will be rolled into 4.11 at the earliest.

avatar image Kartiks Nov 24 '15 at 09:45 PM

I spoke too soon. Reverting 2493547 does not help.

Tim could you provide the CL that fixes this? We can integrate it manually

avatar image Tim Hobson ♦♦ STAFF Nov 24 '15 at 10:19 PM

Hi Kartiks,

The CL is 2766528.

avatar image RVillani Mar 31 '16 at 06:37 PM

In 4.11 release notes:

Bugfix: Cloth was not rendering correctly when cloth assigned to multiple materials

Would this be this thread's solution?! :D I'm asking because we had to use a workaround for months on a project and this would solve it for good.

avatar image Tim Hobson ♦♦ STAFF Mar 31 '16 at 06:55 PM

That's the bug that was fixed with CL-2766528 reported with this post.

avatar image RVillani Apr 01 '16 at 11:06 PM

Awesome! Thanks, guys!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question