x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ART issue (crashing/fatal error)

Hey guys.

So I started working with ART about a week ago. I really like it, makes things a lot simpler and faster and when I ran into some crashing errors, a simple search was enough to find solutions.

Today I updated my model, fixing some minor details and adding some clothes. I then tried to rig it using ART like a did a week ago. However, this time things did not go so smoothly. It seems no matter what I do, when I try to build the control rig I always crash. Here are my details:

Maya 2015

UE 4.8

Things I tried to do after I crashed:

  • re-download all files from the dropbox location (even though I'm pretty sure they were the same files)

  • load and re-save JointMover.mb

  • unload the PhysX plug-in (I'm not sure if this is the same as disabling the plug-in, forgive my inexperience; windows > settings/preferences > plug-in manager > uncheck load and auto load for PhysX)

I decided to try and unload PhysX because between last week (when ART worked fine for me) and today, downloading and loading the PhysX plug in is the only difference. Well that and the fact that it's a slightly different model, but I'm not sure why that would matter.

Any help would be greatly appreciated. Thanks!

EDIT:

  • I have now CONFIRMED that I have to open and resave the JointMover.mb file EVERYTIME I want to use ART. Like, if I close Maya or if Maya crashes, I have to load and resave that file again or I'll crash trying to create even the default rig on the proxy mesh.

  • The fatal error seems to occur only when I try to build the rig with my custom mesh. Going to try and skin more custom models to test this but so far the proxy mesh rigs fine and I also build just the bare skeleton without any mesh that was made for my custom mesh.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 22 '15 at 08:32 PM in Everything Else

avatar image

Sophtastic
11 1 2 5

avatar image Sophtastic Aug 25 '15 at 06:45 PM

So a little update on my issue:

Turns out it has nothing to do with PhysX, If I open and re-save JointMover.mb I am able to create the control rig for just the default set up skinned to the proxy mesh with no problems. However, once I try to repeat the process with my actual mesh, I'm getting a "fatal error: attempting to save in..." I realize this is most likely a problem with Maya, since an internet search revealed that many Maya users run into this issue. I just don't understand why it's happening now. Like I mentioned before, I've gotten ART to work perfectly with another mesh. Yet now it's having issues.

I tried the whole "MAYA_DISABLE_CIP = 1" in the environment variables and that didn't work. It seems that Maya 2015 isn't quite satisfied with that fix...

Also, I don't understand why I can build a control rig for the proxy mesh just fine, but with my own mesh it always gives me the fatal error. This is really strange to me.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok I really have no idea why this fixed the issue but it did the trick:

As mentioned before, I had to open and resave the JointMover.mb file everytime I opened Maya with the intention to use ART. After that, since I knew there was something wrong with the scene that included my custom mesh, I decided to clean up the outliner a bit. I deleted objects that were not going to be used for the rigging process (a hidden arm section and the bottom half of a coat) and a custom select set. I was left with two objects that were going to be skinned onto the skeleton and that worked fine.

I have no idea why this fixes my issue, if anyone would care to explain it to me like I'm 5 I'd love to learn. However, I suppose I should considered my issue resolved at this point.

more ▼

answered Aug 25 '15 at 07:24 PM

avatar image

Sophtastic
11 1 2 5

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question