x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why all UMG animation can't work in UE4.9?

Why all UMG animations can't work in UE4.9? It seems that the module named movieSceneCore was renamed to movieScene. Maybe it's necessary, But, that had a tremendous impact to our project. Because there were so many UI animations in our project. And now , all can't work now!

alt text

Product Version: UE 4.9 Preview
Tags:
moviescene.jpg (234.2 kB)
more ▼

asked Aug 23 '15 at 08:09 AM in Bug Reports

avatar image

awwuwei
51 2 6 6

avatar image Rudy Q ♦♦ STAFF Aug 25 '15 at 02:36 PM

Hello awwuwei,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image awwuwei Aug 26 '15 at 03:37 AM

Hi Rudy, This issue only occurs when you open old version project(such as 4.8) in the new version(v4.9) engine. That means we can't upgrade our project from 4.8 to 4.9 for this issue, except we reproduce all those umg animations in 4.9. And that's will be a huge work to us.

avatar image Slavq Aug 26 '15 at 12:22 PM

So probably reproduction steps would be: 1. Create a project in 4.8 and create an UMG animation. 2. Upgrade this project to 4.9.

I haven't tried to upgrade my project to 4.9 yet, but I also have plenty uf UMG animations, so probably this is my future-bug :)

avatar image awwuwei Aug 27 '15 at 07:16 AM

Yes, it is.

avatar image Rudy Q ♦♦ STAFF Aug 27 '15 at 04:01 PM

Hello awwuwei,

I was unable to reproduce this issue on my end. I tried creating animations and then upgrading to the latest preview. However, I did not receive any errors or having any issues regarding the animations. Please note that the 4.9 version that you are using is a preview build and so it is considered unstable. This preview is meant to test out new features and the preview is not recommended for actual development. I will be happy to assist you further with this issue if/when a reproducible test case is found. Please let me know of any small steps that you may have taken to reproduce this issue on your end.

avatar image awwuwei Aug 29 '15 at 03:12 AM

I had tried again. There was the issue indeed . Even through you can open the 4.8's assets in 4.9 without any warning, But these ui animations can't work at all, And the 4.9 editor will crash when you try to edit the old ui animations.

avatar image Rudy Q ♦♦ STAFF Aug 31 '15 at 04:00 PM

Hello awwuwei,

Could you provide the exact steps that you are using to reproduce this issue on your end? When you say that you tried again, do you mean that you tried this with clean project or that you reproduced this in the same project?

avatar image awwuwei Sep 01 '15 at 10:00 AM

Well, I'll test with clean projects later, then tell you the resault. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

That's greate! The version of 4.9 release dosen't have the problem. And the issue only exists in the preview versions of 4.9!

more ▼

answered Sep 03 '15 at 02:47 AM

avatar image

awwuwei
51 2 6 6

avatar image Rudy Q ♦♦ STAFF Sep 03 '15 at 03:33 PM

Hello awwuwei,

I am happy to hear that your issue has been resolved. I am going to mark your last post as an answer. However, if this problem returns please feel free to reopen this thread with any additional information you have and I will be happy to assist you further.

Make it a great day

avatar image awwuwei Sep 06 '15 at 03:27 AM

Thank you for your kind help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question