x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] Foliage paints on itself?

In 4.8.3 when painting foliage, it now sees other foliage actors as static meshes and will paint on itself which is very annoying. This didn't used to happen in earlier versions. alt text

Product Version: UE 4.8
Tags:
more ▼

asked Aug 23 '15 at 08:07 PM in Bug Reports

avatar image

TorQueMoD
1.1k 81 110 143

avatar image Adam Davis STAFF Aug 24 '15 at 05:03 PM

Hi TorQueMoD,

Does this occur in a blank project with no additional content or is it limited to one project? Are you painting foliage on top of procedurally generated foliage? Is it limited to one mesh or does this occur with meshes from the starter content/other meshes?

avatar image TorQueMoD Aug 27 '15 at 09:23 PM

Hi Adam. Currently its happening in my custom project. Haven't had a chance to try it in a blank project but I'll let you know. I'm painting foliage only. Its happening with all of the speedtree meshes that I purchased from the Speedtree store and imported to the project. Does not seem to be happening with other static meshes that I have imported. In fact with further testing it seems to only be happening in that one map. Not sure how to fix it but at least it doesn't seem to replicate in other maps.

avatar image Adam Davis STAFF Aug 31 '15 at 02:28 PM

Hi TorQueMoD,

Have you been able to reproduce this anywhere else as of yet or is it definitely limited to this map? What are your foliage settings set to?

avatar image TorQueMoD Sep 01 '15 at 07:21 AM

Hi Adam, Haven't been able to reproduce it outside of the one map although I haven't really had time to try much more than just hitting File - New and trying a quick paint as I've been really focused on other aspects of my project. Trying to hit a self-imposed Kickstarter deadline. I'll let you know if it comes up again but I supposed for now we can consider it an occasional glitch and close the issue. Thanks for the help!

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi TorQueMoD,

I understand completely. I'll go ahead and mark this as accepted for tracking purposes. If the error does occur again please post here with updated repro steps and I'll be happy to take another look. Good luck with your kickstarter!

more ▼

answered Sep 01 '15 at 02:30 PM

(comments are locked)
10|2000 characters needed characters left

I had the same problem and I believe it is caused by the collision. I had my collision presets set to "block all" When I revert it back to "no collision" I no longer have the problem.

more ▼

answered Mar 23 '16 at 12:55 AM

avatar image

Lorshank
3 3 2 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question