x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Physics asset constraint bug

Hi, I have a character with shoulder pads which I would like to simulate physics on. My problem lies in the physics asset. When I create a volume for the left pad it creates a volume roughly in the area of that bone, I move and resize that volume, limit motion on the constraint, and it looks and works great. But on the right pad the volume spawns inside the head, when I move it to it supposed position it tries to "flip" back into its original position inside the head. It does not matter how I rotate the constraint or its reference plain (holding alt and rotating), the volume tries to return to that original position, even moving "violently" against the force of gravity or any force I apply.

Please Help, I have been on this for a few days.

Product Version: UE 4.9 Preview
Tags:
more ▼

asked Aug 24 '15 at 03:26 PM in Bug Reports

avatar image

UDKAP
469 29 42 67

avatar image UDKAP Aug 24 '15 at 05:15 PM

bump***

avatar image Tim Hobson ♦♦ STAFF Aug 24 '15 at 05:58 PM

Hi UDKAP,

Please do not bump questions unless it's been at least 3 days of inactivity, not including weekends. This has been assigned to one of our support staff to be looked into. We do have a lot of questions that come in and we will get back to you as soon as possible.

Thank you!

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi UDKAP,

Can you provide a sample video or project that can recreate this that I can take a look at. I can try to recreate the issue, but it would be better with more context to what you're seeing on your end.

From the sound of it, this seems like you've not disable collision for physics bodies that are interacting together. I gather this because the way you describe them "violently" moving.

Try taking a look at the documentation here: https://docs.unrealengine.com/latest/INT/Engine/Physics/PhAT/UserGuide/index.html

You'll want to focus on the Editing Physics Bodies initially.

Thank you!

Tim

more ▼

answered Aug 25 '15 at 04:26 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image UDKAP Aug 25 '15 at 11:16 PM

Here is a video of the problem. And my mesh and Physics asset. http://www.mediafire.com/download/c3o8qh5gf74a7r0/GoT_4.9.rar https://youtu.be/nOhm5bczwQc

avatar image UDKAP Sep 02 '15 at 07:27 PM

Any Progress on this issue?

avatar image Matthew J Sep 02 '15 at 09:56 PM

Hello UDKAP,

I've been taking a look at your physics asset / skeleton and it seems like the issue might actually be with the bones themselves and the joints. The axis for the various joints seem to not be symmetrical which could be causing the odd behavior.

One thing that I noticed immediately is that your LPad is set to Kinematic while the RPad is set to default (Which defaults to simulated). Setting the RPad to kinematic stops this from happening but it'll not be simulating physics of course. You may want to change the LPad to default or at least the same thing for further testing.

I tried moving around the joints as well and recreating the bodies for the pads with limited success, where both pads were having issues.

avatar image UDKAP Sep 03 '15 at 07:46 AM

Hi, thanks for your reply. I went into 3dsmax and redid the bones so that their local axis is aligned with the world axis. I also made the bones as biped extras this time and that fixed the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question