x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FPS cap on Android

I'm trying to make a really simple 2D mobile game for Android. At all times I have like max 10 paper2D sprites on the screen.

My problem is while I test my game on desktop environment I get proper framerates (60 fps capped), but when I deploy it on my phone there seems to be a lower FPS cap.

It caps at 33-34 FPS. alt text

There are no framedrops, only this cap. I disabled every effects, like bloom or AA alt text

I also tried every possible combinations of this. Guides for mobile development did not help me.

Does anyone know how to raise or disable the FPS limit?

Product Version: UE 4.8
Tags:
more ▼

asked Aug 24 '15 at 08:23 PM in Rendering

avatar image

alex47
6 1 2 4

avatar image SolSkyre Dec 23 '15 at 10:31 AM

I would like also want to know how to do this. Limiting FPS in General settings tab cause all the animations run ultra fast.

avatar image alex47 Dec 23 '15 at 10:36 AM

hey SolSkyre, OP here! Your problem is the opposite of mine. Since I posted this problem back in August I discovered that it was NOT an FPS cap, but my phone just could not handle this app, that is why I got low FPS. I think you should open a new thread, because your problem is different then mine was. Cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Go to Project Settings -> General Settings -> Framerate -> Fixed Frame Rate. Neither t.MaxFps not set frame limit in bp works.

more ▼

answered Jul 04 '18 at 03:06 PM

avatar image

MrMcKvarz
241 2 6 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question