x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My editor crashes when opening my project (URGENT)

This has probably been coming for a long while now, this project of mine has been giving me issues and crashing my editor for the past few months (more than once a day), but this is the worst it has gotten.

I can no longer open my game project from the unreal launcher. The editor crashes at 95% in the loading dialog. Here are the events that led up to this:

I had a struct defined in c++ code that was the following:

 USTRUCT(BlueprintType)
 struct FAxonDevice
 {
   GENERATED_USTRUCT_BODY()
   AxonDevice ad;
 };

Due to limitations imposed on struct functionality by Unreal, I needed to change this struct into a class:

 UCLASS()
 class UAxonDeviceClass : public UObject
 {
   GENERATED_BODY()
 public:
   AxonDevice ad;
 };

I made the necessary changes to my code so that the build tool in Visual Studio compiled everything without errors. I then went into the unreal editor and pressed compile, fully understanding how many blueprint errors were about to appear since I had not removed references to the old struct throughout the 5 blueprints that used it. To my surprise the editor crashed during the code compile. This has happened to me dozens of times while working on this project (with a similar amount of crash reports submitted), so I simply restarted the editor. When the editor loaded up it said there was an error, saying that it could not find the old struct in my code. I simply pressed 'ok' hoping I could compile my code successfully and the issue would fix itself, so I tried to compile once more. The editor crashed again.

My next idea was pretty obvious, just add back the old code, but keep the new code. The data types were named differently so it shouldn't cause any issues right? Well, I started the editor back up, ignored the error message, and tried to compile again. The editor still crashed. Well the error message should go away from startup right? I start up the editor, and it crashes before it even opens my project.

I have no idea how to proceed at this point, changes to my code don't seem to fix the issue, I've tried rebuilding from visual studio using the unreal build tools, but nothing allows my project to open again. I would be willing to share any additional information about my situation, if you'd like crash logs just look at the one submitted by me at about 1:30 today.

How can I salvage my project? My company has invested months of my time working on this project, I need to fix this issue.

EDIT: Here is the crash log I'm getting http://pastebin.com/raw.php?i=cB5LLhjw The line in my code that the first line refers to is the "GENERATED_BODY()" macro that I have inside of the blueprint function library class I created. This class has a dozen or so methods that all use my AxonDevice class. This code compiles fine in visual studio. Also here's the launcher log: Launcher Log, and here's the launcher log with debugging mode on : https://drive.google.com/file/d/0B3u_hzolRrMjTXczVUJtQ1pJZ2c/view?usp=sharing

EDIT 2: I've traced the error's root to my usage of my class extending UObject. I've determined that I probably cannot have two UCLASSes in the same file, seeing as each needs to include their own generated header file, and you can only include one per file. I have reverted every change I made to my source files, replacing all usages of my class with my struct once again. I have rebuilt my code, but the editor still crashes on startup. At this point, since the changes in my code have been completely undone, with no reference, declaration or definition for that class still existing, the only thing I can do now without access to the editor is delete files.

EDIT 3: Here is the call stack at the first exception thrown from debugging the Editor in VS2015: http://pastebin.com/raw.php?i=SsGfGL3C

Product Version: UE 4.8
Tags:
more ▼

asked Aug 24 '15 at 09:03 PM in Bug Reports

avatar image

janimationd
424 20 95 122

avatar image Devero Aug 24 '15 at 09:13 PM

Go ahead and attached the log and crash files here also. Fellow devs don't have access to that information that could help you out =)

avatar image janimationd Aug 24 '15 at 11:57 PM

I've added as much info as I could gather.

avatar image Doug E ♦♦ STAFF Aug 25 '15 at 01:37 PM

Hey janimationd-

You said that you did revert the code to what it was before the crash started (with the struct intact and without the class) and the crash is still occurring? Does the code compile successfully inside VS? Could you send the callstack from the crash as well?

Cheers

Doug Wilson

avatar image janimationd Aug 25 '15 at 04:19 PM

Yes, I did completely eliminate all usages of the class and re-instituted the struct in my code. Grep-ing my project directory and visual studio solution come up with no occurrences of the class name. The visual studio project for my project compiles fine in VS for development, which is what my unreal project was using. I will update my question to include the call-stack shortly.

avatar image janimationd Aug 25 '15 at 05:18 PM

Here's the VS debugging callstack http://pastebin.com/raw.php?i=SsGfGL3C

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey janimationd-

Could you post the crash report callstack (the black window that pops up after a crash when not running in VS debug mode) as well as the project logs in the Saved/Logs folder of the project directory? Additionally are you able to successfully build the project in DevelopmentEditor rather than Development? Let me know if this helps at all either.

more ▼

answered Aug 25 '15 at 05:36 PM

avatar image janimationd Aug 25 '15 at 05:41 PM

Building in Development Editor works, and I can open my project now. Thanks!

If you still want to see the callstack you're talking about, it's the first link under "EDIT:" in the question (http://pastebin.com/raw.php?i=cB5LLhjw).

avatar image gozu Oct 17 '15 at 02:10 AM

Same issue here and this resolved it for me, Building in Development Editor. Thank you!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question