x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Building Failed for Windows

Trying to package my game when after a while it said that Automation Tool failed to run successfully, and that the build was terminated? How would I fix this? KERNELBASE.dll!UnknownFunction (0x00007ffc6f0943c8) + 0 bytes [UnknownFile:0] Build failed

Product Version: UE 4.7
Tags:
more ▼

asked Aug 26 '15 at 02:43 AM in Packaging & Deployment

avatar image

Rajgamer
1 2 3

avatar image Rajgamer Aug 26 '15 at 02:48 AM

"LogFile"

log.txt (2.6 kB)
avatar image Samantha Sutton ♦♦ STAFF Aug 26 '15 at 09:03 PM

Hey Rajgamer,

In order to further assist you, could you please provide me the output logs from this specific error in 4.7? Also, have you been able to create a copy of your project and test the packaging in 4.8.3 or 4.9 Preview 4? If so, could you please provide me those logs as well?

Thanks!

avatar image Rajgamer Aug 30 '15 at 09:39 PM
error.txt (1.7 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Update the following section in your Engine/Config/BaseEngine.ini and rebuild. I believe you are not building with windows xp support switched on correctly for UBT to use.

 [/Script/WindowsTargetPlatform.WindowsTargetSettings]
 MinimumOSVersion=MSOS_XP


/Terence

more ▼

answered Sep 14 '15 at 08:35 AM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey RajGamer,

Seems the error is in your map, "Shooter" try openening the map and address any issues, then resave before cooking again.

 MainFrameActions: Cooking (Windows): UE4Editor-Cmd: [2015.08.19-01.30.57:951][  0]LogLinker:Warning: The file '../../../../../Users/SuccessfulGamer/Documents/Unreal Projects/FPSGame/Content/Maps/Shooter.umap' contains unrecognizable data, check that it is of the expected type.
 MainFrameActions: Cooking (Windows): UE4Editor-Cmd: [2015.08.19-01.30.57:953][  0]LogCookCommandlet:Warning: Package /Game/Maps/Shooter supposed to be fully loaded but isn't. RF_WasLoaded is not set
more ▼

answered Sep 01 '15 at 09:17 AM

avatar image Rajgamer Sep 09 '15 at 07:22 PM

solved above errors but still different problem once watch below log2 link text

log2.txt (44.3 kB)
avatar image Terence.Burns Sep 11 '15 at 08:36 AM

Hey RajGamer,

Windows XP support should only available to those with full GitHub source. The problem here is that the engine object files and headers are not distributed for windows XP. So if you seek to use windows XP as your target minimum OS, then you will need to rebuild the entire source from Visual Studio.

Hope this helps.

/Terence

avatar image Rajgamer Sep 10 '15 at 10:45 AM
package log3.txt (4.7 MB)
avatar image Samantha Sutton ♦♦ STAFF Sep 10 '15 at 05:02 PM

Hey Raj,

It looks like you have the following errors:

 MainFrameActions: Packaging (Windows (32-bit)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Users\SuccessfulGamer\Documents\Unreal Projects\FPSGame\Binaries\Win32\FPSGame-Win32-Shipping_XP.exe

Try deleting your saved, intermediate and config files and packaging again. In the meantime, I will be asking for additional assistance to review your log to ensure nothing major is happening.

Looking forward to hearing back from you regarding the deletion of those files, and whether or not that has solved your problem.

avatar image Rajgamer Sep 11 '15 at 02:33 PM
log4.txt (45.3 kB)
avatar image Terence.Burns Sep 11 '15 at 02:50 PM

Hey RajGamer, See my comment above^

avatar image Rajgamer Sep 11 '15 at 03:27 PM

yes i did it, i rebuilded my entire project with visual studio. But still the same problem

avatar image Samantha Sutton ♦♦ STAFF Sep 11 '15 at 05:59 PM

Did you build it for Windows 32 and 64 bit?

avatar image Rajgamer Sep 12 '15 at 07:16 AM

windows 32

avatar image Rajgamer Sep 12 '15 at 07:17 AM

there was an error msb8020

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question