x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

animations dont work in standalone game but do in editor

As the subject says. As soon as I start standalone game or package it or try and take a video all the animations for a specific animBP revert to TPOSE. since I have 40+ chars AI using this animBP its really messing things up for me. I'm deep into trying to take videos of scenes right now and for the last 5 hours its been working fine til right now. And im very much trying to not to SNAP the eff out because obviously my videos look ridiculous right now. And I can't move forward. This happened to me on 4.7 forcing me to upgrade to 4.8 and now its happening again and its so damn frustrating!

No I can't tell you how to reproduce it because it just friggen happens after months of working fine. Everything looks great in the editor but soon as you standalone in anyway it goes to hell. All the AI logic works. So the chars move and run around in tpose... great.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 27 '15 at 09:43 PM in Bug Reports

avatar image

thankstipscom
654 39 38 72

avatar image thankstipscom Aug 27 '15 at 09:25 PM

restarting the editor several times 'fixed' it.

dont know why or how.

avatar image thankstipscom Aug 28 '15 at 07:27 PM

this is actually a relevant bug that needs to be looked into. my animiations are working again but the core looks like it reverts ALL variables to zero.

So the 150+ variables that had settings in them in the affected blueprint are now all zeros and need to be reset manually.

very time consuming

avatar image thankstipscom Aug 28 '15 at 10:01 PM

that includes all arrays and some animation settings since theyre all messed up. not sure which settings yet..... wow. all day spent re-adding all defaults ...

avatar image Steve Hardister ♦♦ STAFF Aug 31 '15 at 06:57 PM

Hi thankstipscom,

I know we've requested your files before and you said they were too large to send. However, you can migrate just the blueprint in question (plus all directly related assets that should migrate automatically) to a blank third person project, then send that project in a zip file.

You can attach it here, if small enough, use DropBox or send as an attachment in a private message to me on the UE4 Forums. I suspect it is an issue with orphaned classes as you have mentioned before, but we may be able to patch things up here, get it stable and send it back. -At least that's what I'm hoping.

Thanks

avatar image Steve Hardister ♦♦ STAFF Sep 09 '15 at 03:54 PM

Hi thankstipscom,

Since we have not heard back from you in a while, I am closing this post for tracking purposes. I you would like us to look at your files in order to troubleshoot, you can still reply to this post and submit your files following the guidelines that I last posted.

Thanks

avatar image thankstipscom Sep 09 '15 at 04:57 PM

yea sorry I havent had the time. Ive had to redo a bunch of work due to a crash that corrupted a map. I've seen a lot of posts on the forums about the same issue though. I dont think its my project specifically.. maybe just the size of certain blueprints There's just bugs in the editor i guess.. I send the crash reports most of the times. Hopefully they get worked out.

Thanks

avatar image thankstipscom Sep 09 '15 at 07:21 PM

literally just happened again. All my variables reset to zeros, arrays empty etc... anims all in tpose after crash Looks like i had a video driver crash with trying to test play. I have a backup from yesterday I can revert to and not lose much this time. I restarted the PC and crash report popped up then. I sent it but it shows nothing in the report. Project is called Scene02

maybe you can find something hidden in the crash report to track down why the variables all get reset somtimes

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi thankstipscom,

I was able to locate your crashes on our Crash Reporter page and the majority show the following error message: "Access violation - code c0000005 (first/second chance not available)." However, while they share the same error, all but the last two have different Callstack readings (meaning same error, but different specific causes of crash.)

The upswing is that one of these has been reported fixed in 4.9. Therefore, I suggest keeping a copy of the 4.8 version, but making a copy and opening it in 4.9. Please try this and let us know if there's been any improvement.

Thanks

more ▼

answered Sep 10 '15 at 03:51 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question