x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Animation from Maya not importing / Incorrect transform

I had successfully exported animation data using Maya 2016's 'Game Exporter' option, but after importing into Unreal, my running animation was rotated 90 degrees onto the ground.

I went back to make sure Maya's scene preferences and export settings were set to Z-axis up, as they were.

So I copied to a new file in Maya and tried again, exporting with these settings:

alt text

The FBX preview played like this, although it seems my problem would be in the inappropriate inclusion of the mesh and control rig into the animation FBX, I had done the same procedure previously, and my animation played in Unreal without issue, besides the incorrect rotation:

alt text

Then imported to Unreal:

alt text

I still received the 'Imported bone transform is different from original' error, but now the imported animation was looping a single frame, still on the ground without animation data.

I'm not sure where or which settings were changed, and can't seem to make the animation play again after much fiddling with settings.

Any help is appreciated, thank you.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 29 '15 at 08:00 PM in Using UE4

avatar image

zmalsberg
36 2 7 11

avatar image zmalsberg Aug 30 '15 at 06:38 PM

This is the rig, if anyone knows what's wrong with it.

avatar image Steve Hardister ♦♦ STAFF Sep 01 '15 at 08:56 PM

Have you tried setting the export option to FBX Version 2014? I'm not sure 2016 is supported yet.

avatar image Steve_T Sep 03 '15 at 04:28 PM

Yeah FBX 2016 doesn't work sometimes (not at all for me) with UE4.8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Solved these two problems... The rig's skeleton 'visibility' channel was set to 'off', which prevented it from exporting.

As for the rotation issue, I just had to roll the animations 90 degrees on import.

A weird requirement, but it works.

more ▼

answered Sep 04 '15 at 07:07 PM

avatar image

zmalsberg
36 2 7 11

avatar image Steve Hardister ♦♦ STAFF Sep 04 '15 at 07:21 PM

Glad to hear you got it resolved and thanks for taking the time to post your solution. This will likely help users experiencing similar conditions with the latest FBX exporter.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question