x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

On click/On touch not working in 4.8.3

Hej! I dont know if this is a bug or if its because of the additional new output, but this setup worked in the previous version of 4.8, but now it doesnt. Now, i noticed the new output, that says touched component, is it because you have to link it to something to work?

alt text

Product Version: UE 4.8
Tags:
on click pic.png (343.1 kB)
more ▼

asked Aug 30 '15 at 12:34 PM in Bug Reports

avatar image

MarcusH
1 1 3

avatar image Rudy Q ♦♦ STAFF Aug 31 '15 at 02:12 PM

Hello MarcusH,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any other blueprints that may be involved with this issue ( such as your player controller)

  4. Do you have have click events enabled?

avatar image MarcusH Aug 31 '15 at 03:38 PM

Hi Rudy! Thanks for the quick response. I just tested it out in a new clean project, and it seem to work fine. I just setup a custom controller with click and touch events trace and apply a onclick and ontouch events on a static mesh cube, so that it opens a new level. The static mesh is hidden in game. I dont know if this is relevant, but i tried converting the project in target hardware from maximum quality to scalable 2D and 3D, and back, and when i did, some shaders such as unlit opaque materials were no longer rendered, so i had to migrate the project to another project. The project is also set to target Mobile/Tablets, if thats any help.

alt textalt text

menu controller.png (151.7 kB)
gamemode.png (133.9 kB)
avatar image Rudy Q ♦♦ STAFF Aug 31 '15 at 05:55 PM

Hello MarcusH,

Does this issue still occur when the object is not set to "Hidden in Game"? Would it be possible for you to zip down a simplified version of the project and send to us so that I can take a closer look at the issue?

avatar image MarcusH Sep 01 '15 at 02:36 PM

Hej Rudy! I just tried it, and yes, it still doesnt fire when its visible and not hidden in game. I have made simplified version with just the menu as is. Funny in the same new test project, if i do it with something else, it works....link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello MarcusH,

After looking into your issue and downloading the project I was able to figure out what the issue was. The game mode that is assigned to the "MainMenu" level was different from the game mode that was used in the other levels. This is why the issue did not occur anywhere other than that specific level. Open the "Main Menu" level and go to your world settings and change the game mode to "nugamemode" and this will solve the clicking issue that you are having.

Make it a great day

more ▼

answered Sep 01 '15 at 05:34 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image MarcusH Sep 01 '15 at 06:44 PM

Ah, thank you ver much Rudy! I will try that out tomorrow. And thanks for the quick response. And great day to you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question