x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sound direction bugged on linux

Positional Audio is bugged on linux.

To replicate:

  1. Play a sound left from the playing character

  2. Turn the playing character 180° and play the sound again

Expected: The sound is heard as coming from 2 different places

What happen: The perceived position is the same. In Addition the sound doesn't doesn't come from the correct location.

More details: If you play a sound from a moving object, the sound move, but the direction is wrong and doesn't account for the player rotation.

I replicated this bug cloning both unreal tournament and unreal engine repos.

This bug can be seen even on Unreal Tournament 4: the direction the sounds come from doesn't take into account the player orientation.

These 2 bug report present the issue:

https://forums.unrealtournament.com/showthread.php?13580-sound-in-linux [1]

https://forums.unrealtournament.com/showthread.php?17466-Some-audio-only-outputting-in-right-channel [2]

This video (not mine) further illustrate the bug:

https://www.youtube.com/watch?v=x8JB0O6a9TI [3]

Notice how the projectile sound always come from the left. The direction the sound come from seems to change from map to map.

EDIT: 4.9 Changed some things but the sound is still broken. I have now identified the issue:

EDIT2: 4.9 Actually Fixed things, i was wrong. I made a dumb mistake with the project I used to debug this.

Product Version: UE 4.8
Tags:
more ▼

asked Aug 30 '15 at 04:13 PM in Bug Reports

avatar image

Overload
8 4 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Overload-

Could you elaborate on what exactly you're experiencing? I tried using the PlaySoundAtLocation on both Windows and Linux and the sound played the same on both. Could you provide examples of which sounds are not playing correctly for you?

Cheers

Doug Wilson

more ▼

answered Aug 31 '15 at 07:46 PM

avatar image Overload Sep 01 '15 at 12:25 AM

Sorry, I made a really dumb mistake in the project I used to test 4.9. Spatialized sounds actually work correctly now, this issue can be closed.

The only very minor thing is that in Runtime/ALAudio/Private/ALAudioSource.cpp there is a bit of dead code: the local variable Location in Update() is assigned but never used.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question