x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Strange lines appear in tilemap

Dear Epic/Community,

While building my sidescroller in Paper2D, I've encountered a really annoying problem with my tilemap. As you can see in the first image, sometimes a line appears on the edge of 2 tiles in my tilemap. The exact location of the line switches around, but it always appear on the vertical 'grid-line' between two tiles. At first I only noticed it while previewing my game, but after (literally) closer inspection in the editor (read: zooming in) it also happens there.

At first I thought it had something to do with the light-blue background, but after removing the background, the problem remained.

My next guess was that somehow the tiles had become bigger than the grid, but both are set at 32px by 32px (I've painted the tiles on a 32 by 32 grid in Photoshop, so that shouldn't be a problem).

I've tried applying the "Paper2D texture settings" to the source-image before and after creating the tileset and tilemap, but that didn't help either.

I also tried reducing the size of the collision-tile to prevent possible overlap, but even after using 28 by 28 collision-boxes on the 32 by 32 tiles, it still occurs.

My last guess was to use a source-image with a spacing in between the different tiles, so I've tried 1px- and 2px-wide spacing between the tiles in the source-image and the problem is still there.

Does anyone have a clue what could be causing this issue?

Thanks in advance!

Product Version: UE 4.9
Tags:
screenshot1.png (932.9 kB)
screenshot2.png (187.4 kB)
more ▼

asked Aug 31 '15 at 05:52 PM in Bug Reports

avatar image

Diotima
1 1 2 4

avatar image Logan Bailey ♦♦ STAFF Aug 31 '15 at 08:48 PM

Hello Diotima,

Thank you very much for reporting this issue. This is a known issue and has been reported to our development team.

Here is a link to another user who was experiencing the same issue.

https://answers.unrealengine.com/questions/290886/graphical-artifactsglitches-when-using-tilemaps.html

The bug number is UE - 20468.

Again, thank you for reporting this Bug to us,

Logan

avatar image Diotima Aug 31 '15 at 09:35 PM

Thanks for the quick response!

Hopefully you can squash that buggy soon :)

avatar image TouchYourFace Dec 27 '16 at 01:45 AM

I'm getting the exact same thing and I'm on the latest version?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey guys,

This was determined as 'Invalid' see the Developer Notes in the bug link I have provided below.

UE-20468

Thank you and let me know if you have further questions.

Andrew Hurley

more ▼

answered Mar 06 '17 at 05:07 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question