x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash on Set Actor Rotation - 4.9 only

Hi there.

I'm making a bug report although this is a completely ridiculous problem that doesn't make any sense to me and I'm not sure if it will be reproduce-able because it's bizarre.

What I have is a single object made up of multiple components, attached to another object made up of multiple components. When I press E on either object, it rotates the parent object - essentially a door situation. This whole set up I had in place in 4.8 with no crash. Now, in 4.9, when I press E and start the rotation, it crashes inexplicably with no error message or anything.

I've used breakpoints and found it crashes as soon as the 'Set Actor Rotation' function is called. I tried replacing it with other methods of changing the rotation, like setting the actor's relative rotation or setting the root component's relative or absolute rotation, but the crash remains. I've tried printing the rotator, and there doesn't appear to be anything strange with it when it's printed.

The very strange thing is that there are circumstances where I can make this crash not occur. If the object I am rotating is located in different areas, it will crash or not crash. Most areas it crashes though. If it's just the one object (the hinge parent) it doesn't crash, but if there's a hinge child attached, it crashes. If that hinge child is made up of 1 component, it doesn't crash, but if it's made up of 2 or more, it crashes.

I've tried changing the rotator formula (I set the rotation to each of the rotator values used in the process, and it crashed for some and not for others - for example, it doesn't crash on 'Hinge Closed Rot' or on 'Rotator from Axis and Angle' but it does crash if the 'Combine Rotators' result is used. I still have my 4.8 version of UE4 and this code does not cause ANY crashes in that version, only in 4.9.

It's put me at a bit of a standstill because there's no way for me to do what I need to do without rotating the object, and no matter how much I mess with it the only consistent way to stop the crashing is to skip over the rotate function which is not possible for this to work right. I really hope this bug can be fixed because it doesn't make any sense to me that there's a crash occurring from something as basic as setting a rotation, although I don't get this crash anywhere else in my project that I know of and this isn't the only place that I set rotation for an object, so I don't know what that's about.

alt text

Product Version: UE 4.9
Tags:
more ▼

asked Sep 01 '15 at 06:01 AM in Bug Reports

avatar image

DylanBrady
71 7 12 18

avatar image Ben Halliday STAFF Sep 01 '15 at 02:39 PM

Hi DylanBrady,

Are you able to reproduce this in a new test project in 4.9? If so, please upload that somewhere so we can take a look.

It would be helpful to take a look at the crash log from your project's \Saved\Logs folder. Please zip and attach them here. Please also copy the information from the Crash Reporter window after this crash occurs, including the Machine ID, and paste it here. Make sure you hit Send for the crash report!

avatar image DylanBrady Sep 02 '15 at 05:13 AM

Hi Ben! Sorry, I went on here to add some additional information 'cos I've figured out more accurate information for this now. I'm starting up a test project now to verify if I can reproduce it there, and I'll post the results once I do that (should be ~10 mins)

Important details for now: This is not a problem with Set Actor Rotation, or with the rotation amount that is put in or anything of the sort. I've discovered what is the cause of the crash, though I don't know how to stop it. It's a little convoluted so let me explain through an example:

I have an actor named LogActor, which is the actor I use for all of this. Say LogActor1 is created with a root component, and ~10 other components attached to it. I strike that object with a weapon, it "cuts it in half" by taking 5 of those components and attaching them to a newly created object, Object 2.

Thus, after this point, LogActor2 is made up of a root component (created by/owned by LogActor2) and 5 components that are originally part of LogActor1 and still technically owned by it, though attached to LogActor2.

Now, I have a system to place a LogActor on the ground and click on it to rotate it. Other objects can be attached to it so that they rotate also. The problem occurs 100% of the time if LogActor1 is on the ground and I attach LogActor2 to it, as long as LogActor2 has at least 1 component that was "originally" part of LogActor1. The crash also occurs if I attempt to modify location, not just rotation. It does not occur if I modify scale. It does not occur if LogActor2 is the base with LogActor1 attached to it, or any other situations than the one I described.

avatar image DylanBrady Sep 02 '15 at 05:18 AM
  • Continued: All of the previous conditions that I used to think were causing the crash - i.e. amount of rotation, where I was on the map and so on - were irrelevant, the problem was occuring because I was randomly using LogActor1 as the base during tests and other times using LogActor2 and then mis-attributing the crash to other factors.

The crash does not pop up with the Crash Reporter window, so I can't use that for sending a crash report or copying any information. I did go to the location you suggested and look in my logs, and the most relevant-looking thing I could find looked like this:

 [2015.09.01-02.56.18:908][ 94]LogActorComponent: UnregisterComponent: (/Engine/Transient.EditorFloorComp) Not registered. Aborting.
 [2015.09.01-02.56.19:117][ 94]LogActorComponent: UnregisterComponent: (/Engine/Transient.EditorFloorComp) Not registered. Aborting.
 [2015.09.01-02.56.19:488][ 95]Cmd: QUIT_EDITOR
 [2015.09.01-02.56.20:851][ 95]LogExit: Preparing to exit.
 [2015.09.01-02.56.21:634][ 95]LogExit: Editor shut down
 [2015.09.01-02.56.21:635][ 95]LogExit: Transaction tracking system shut down

LogActor is the object I'm talking about, and it has numerous components (the Root component is called RootLog, and the component that the txt file is referencing seems to be one of the components I add to it via blueprints during actor generation)

Essentially, the gist of what's happening from what I can tell is that the components are created attached to an actor, detached from that actor and attached to a new one, and then the new actor that they are attached to becomes attached to the old actor they used to be attached to and then once it is told to move or rotate it crashes.

Knowing the ability to reproduce the crash, I re-tried it in 4.8 and did not get the crash, so it is definitely only occuring in 4.9.

I will post one more comment after this with the results from attempting to reproduce this in a test project.

avatar image DylanBrady Sep 02 '15 at 06:20 AM

I have reproduced this problem in a test project! I've created it and added some documentation so you guys can easily follow along. If you press play, the Spawner will create the actor and go through a few steps over a few seconds, after which it will crash once it tries to rotate.

I started it with all the starter content (on accident) and then ended up deleting most of that to cut down the file size so I could upload it easier, so there might be some loading errors when you open it up but those aren't important and have nothing to do with the issue. (Just to be totally sure - the crash was occurring before I deleted those files)

Here's the mediafire download link, let me know if this doesn't work. https://www.mediafire.com/folder/spl6vav6xwdfv/TestProject

Thanks for your attention and I hope this helps you guys fix it!

avatar image Ben Halliday STAFF Sep 02 '15 at 03:09 PM

Hey DylanBrady,

Thanks for looking into it further and providing a test project for us! I'd like to download it, but it won't let me without upgrading to MediaFire pro because it's not already zipped up. If you could try either Dropbox or Google Drive, or zip it up first and then use MediaFire, that would allow me to get it.

The log snippet above shows a successful exit from the editor, so while it may be related I don't think it's what we need. If you can find the log that is saved immediately after the crash occurs, that would be most helpful. Thanks!

avatar image DylanBrady Sep 02 '15 at 08:54 PM

Ah, sorry about that! I put it into a .rar file now, hopefully that works! http://www.mediafire.com/download/hwcb2clxgaexcca/TestProject.rar

If not, I can definitely use Google Drive or Dropbox, but I would need an email to send you guys an invite to to be able to access it. Let me know if this works.

Unfortunately, as far as the logs immediately after the crash occurs, I don't see any being added when the crash occurs even with keeping the Saved/Logs folder open on my other monitor and watching it.

avatar image Ben Halliday STAFF Sep 02 '15 at 09:35 PM

Okay, no problem. I was able to get it with this link, and I'll take a look as soon as I can. Thanks!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello DylanBrady,

I have written up a report (UE-20764) and I have submitted your project to the developers for further consideration. I did however find a workaround within the sample project that allowed the object to rotate without causing the crash. I added a scene component as the root component (making it the parent of "CrashTestRoot" ). This was the only change needed for the test project. I hope that this information will allow you to find a workaround in your actual project.

Make it a great day

more ▼

answered Sep 03 '15 at 09:16 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image DylanBrady Sep 04 '15 at 05:30 AM

Thanks Rudy! I'm glad that it's been reported! That workaround sounds pretty efficient, unfortunately it won't work for my project with some of the things that I do involving the root (simulating physics and all that), but in the short term (at least until the next patch or two) it's not a big problem because it works fine just so long as I don't use the root as the base, which means I can use any other part that I chop off as the base. So it's not an immediate concern but definitely something that I will appreciate when it's fixed because it wouldn't do so well for playtesting and stuff later in development.

Anyway, once again thanks to you both!

avatar image Ben Halliday STAFF Oct 08 '15 at 08:33 PM

Heya Dylan,

Looks like this specific crash has been fixed in 4.10. The 4.10 preview branch should be released in the near future, so please let us know if you continue to run into the crash. Thanks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question