x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Tesselation Material not compiling

Hi,

I have created a tesselated material, and it doesn't work on my static mesh (a quite simple very polygonal tree) but does work on primitive (cube). I already had the problems in 4.8 with other meshs, but at the time I thought it was because of their complexity, but when I updated my project to 4.9 the tree that did look good on 4.8 lost his material (he has the default grey one) unless I remove the tesselation.

I could do without the tesselation, but anyone knows about this bug? (if it is one)

edit : it is a PN triangles tesselation with 1 multiplier

Product Version: UE 4.9
Tags:
more ▼

asked Sep 01 '15 at 11:22 AM in Rendering

avatar image

Gerry93
40 1 6 10

avatar image Logan Bailey ♦♦ STAFF Sep 02 '15 at 01:37 PM

Hello Gerry93,

I am sorry you are experiencing this issue. If you would please link me a screenshot with steps you used to produce this issue. Also, if you could elaborate on not working.

Does the tesselation not occur or is not doing what you expect it to.

Thank you,

Logan

avatar image Gerry93 Sep 02 '15 at 02:11 PM

My asset is a tree, and in 4.8 I use tesselation just to smooth the mesh, now I updated my project in 4.9 the shader appears as the default one, without any tesselation. I could just import a tree with more subdivs, but it's not only on this mesh I've got this problem, do you know why ? My process is simple, I import my mesh, put my material, activate PN triangle tesselation. It is a static mesh with different material element.

exemple without tesselation/ with tesselation

alt text

alt text

withouttess.jpg (54.9 kB)
withtess.jpg (46.0 kB)
avatar image Logan Bailey ♦♦ STAFF Sep 02 '15 at 02:57 PM

Hello Gerry,

I did a test with a cylinder. I created it in Maya and added a smooth edge after beveling the top Edge.

alt text

I then imported that into UE4 and set up tesselation with PN Triangles with a 0 multiplier.

alt text

Then I changed that multiplier to 2.

alt text

Note the amount of smoothness when increasing the tesselation. As a rule you will need smoothing groups on your mesh in order for the smoothing to occur inside of UE4. If you go to wireframe mode in your viewport you will see the tesselation occuring without actually smoothing anything, if you have no smoothing groups.

Let me know if this helps.

Thank you,

Logan

cylinder_maya.png (198.0 kB)
smooth_ue4_0.png (653.7 kB)
smooth_ue4_2.png (650.9 kB)
avatar image Gerry93 Sep 02 '15 at 03:15 PM

Hi Logan,

It is the result I expected, but when I turn on tesselation on my material, it seems like it does not compile and my tree appears with the default grey material, that's my problem. This same material does work on a primitive cube though.. So it must be because of the tree mesh.

thank you for your help!

avatar image Logan Bailey ♦♦ STAFF Sep 02 '15 at 03:35 PM

Hello Gerry93,

Not a problem. Glad I could help narrow down the issue for you. If you are willing I can test this out in a controlled project.

What I would need for that is your .uproject, content, and config folders. This way I can test that exact mesh on my machine and investigate this issue further without guess work.

Let me know if you would be willing to do this.

Thank you,

Logan

avatar image Gerry93 Sep 02 '15 at 03:39 PM

my project is quite heavy, is that okay if i give you just the static mesh asset and material ?

avatar image Logan Bailey ♦♦ STAFF Sep 02 '15 at 03:40 PM

Yes, that should be fine.

avatar image Gerry93 Sep 02 '15 at 04:06 PM

link text Here you go, please let me now if you find something,

avatar image Logan Bailey ♦♦ STAFF Sep 02 '15 at 05:28 PM

Hello Gerry93,

If you would please link me your .fbx. As .uassets are project specific and will not open within a new project.

Thank you,

Logan

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I just find the problem when testing my fbx ! I forgot to check "Build adjacency Buffer" in the FBX import options windows. It works well now, so it was my mistake,

thank you very much for your help :)

more ▼

answered Sep 03 '15 at 09:24 AM

avatar image

Gerry93
40 1 6 10

avatar image Logan Bailey ♦♦ STAFF Sep 03 '15 at 01:25 PM

Hello Gerry93,

Not a problem. Glad I could help.

Logan

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question