x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Character falling in Blueprint viewport

After upgrading from 4.8 to 4.9, I've noticed my Character appears to be falling in the Blueprint viewport (see the screenshot.) Before the engine update he was using the idle animation where he stands, but now he starts to fall when the viewport tab is opened.

The Character Blueprint is based off a C++ class, whose parent class is ACharacter. The base C++ class's constructor looks like this:

     // Set size for collision capsule
     GetCapsuleComponent()->InitCapsuleSize(50.0f, 100.0f);
     GetMesh()->SetWorldLocationAndRotation(FVector(0.0f, 0.0f, -100.0f), FRotator(0.0f, 270.0f, 0.0f));
 
     // set our turn rates for input
     BaseTurnRate = 45.f;
     BaseLookUpRate = 45.f;
 
     // Don't rotate when the controller rotates. Let that just affect the camera.
     bUseControllerRotationPitch = false;
     bUseControllerRotationYaw = false;
     bUseControllerRotationRoll = false;
 
     // Configure character movement
     GetCharacterMovement()->bOrientRotationToMovement = false; // Character moves in the direction of input...    
     GetCharacterMovement()->bUseControllerDesiredRotation = true;
     GetCharacterMovement()->RotationRate = FRotator(0.0f, 540.0f, 0.0f); // ...at this rotation rate
     GetCharacterMovement()->JumpZVelocity = 600.f;
     GetCharacterMovement()->AirControl = 0.2f;
 
     // Create a camera boom (pulls in towards the player if there is a collision)
     CameraBoom = CreateDefaultSubobject<USpringArmComponent>(TEXT("CameraBoom"));
     CameraBoom->AttachTo(RootComponent);
     CameraBoom->TargetArmLength = 300.0f; // The camera follows at this distance behind the character    
     CameraBoom->bUsePawnControlRotation = true; // Rotate the arm based on the controller
 
     // Create a follow camera
     FollowCamera = CreateDefaultSubobject<UCameraComponent>(TEXT("FollowCamera"));
     FollowCamera->AttachTo(CameraBoom, USpringArmComponent::SocketName); // Attach the camera to the end of the boom and let the boom adjust to match the controller orientation
     FollowCamera->bUsePawnControlRotation = false; // Camera does not rotate relative to arm
 
     // Note: The skeletal mesh and anim blueprint references on the Mesh component (inherited from Character) 
     // are set in the derived blueprint asset named MyCharacter (to avoid direct content references in C++)
 
     AutoPossessAI = EAutoPossessAI::PlacedInWorldOrSpawned;

alt text

Update: Okay, I did some more testing now. I disabled "Auto Possess AI" in the Blueprint (in other words, invalidated the last line of code in the constructor), reopened the window, and now he's standing there like he used to. I tried each of the options for that property, and it seems like it only happens when it's set to "Spawned" or "Placed in World or Spawned".

I suppose because I'm possessing him with an AI Controller on spawn, he thinks he's supposed to be falling in the Blueprint editor too. I'm not sure if this is intended or wise - at least to me it's pretty annoying, but if anyone has a good explanation for it, I'm all ears.

However, I went back to the old commit, the one before the upgrade from 4.8.3 to 4.9, and the same behaviour could be seen there, so I was mistaken in thinking it was because of the upgrade.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 01 '15 at 03:07 PM in Bug Reports

avatar image

ThomasKasene
21 2 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey ThomasKasene-

I was able to reproduce the falling animation simply by setting the Auto Possess AI inside a blueprint and have reported the bug (UE-20732) for further investigation.

Cheers

Doug Wilson

more ▼

answered Sep 03 '15 at 05:40 PM

avatar image Kaffeetrinker Nov 13 '16 at 05:36 PM

I found this post because I have this in 4.13.2

avatar image Doug E ♦♦ STAFF Nov 14 '16 at 02:32 PM

Hey Kaffeetrinker-

You can work around the falling animation by changing the setting for Auto Possess AI from "Spawned" or "Placed in World or Spawned". This issue is still open in our system and you can track the report's status here: https://issues.unrealengine.com/issue/UE-20732 .

avatar image Kaffeetrinker Nov 14 '16 at 03:17 PM

Thanks for the info, I just wanted to comment here, because in the bugtracker, it only listed the older version, so I thought I should mention this with 4.13 in case someone searches for that version. I've now created a base blueprint with no AI and a child blueprint with AI. So it does not bother me that much.

avatar image TorQueMoD May 06 '19 at 01:50 AM

Changing the Auto Possess AI setting to Disabled and then closing the blueprint and re-opening didn't affect anything for me. The character is still constantly falling in the editor which makes it a lot more difficult to work with.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question