x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BP Instance Error: Externally Referenced

I just upgraded my project to 4.9

After upgrade i come across a problem i couldn't resolve myself.

I have BP_ChessBoard which inherites ChessBoard(c++ class) and i placed an instance to my current map.

Now that instance gives me this error: This map is using externally referenced packages which won't be found when in a game and all references will be broken. Perform a map check for more details.

BP_ChessBoard_2 StaticMeshComponent CurrentMap/BP_ChessBoard_2: Externally Referenced

StaticMeshComponent is created inside c++ class ChessBoard.

I have looked around a lot for any problem, but couldn't find what is wrong.

Thanks in advance for help.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 01 '15 at 06:11 PM in Everything Else

avatar image

Corpse0327
186 26 25 35

avatar image jtsmith Sep 01 '15 at 06:16 PM

I was just coming to post this same question, though I don't inherit anything from C++. I am using just the map that came with the Top Down template but I deleted all static meshes and created a landscape and still get the error:

This map is using externally referenced packages which won't be found when in a game and all references will be broken. Perform a map check for more details.

avatar image Corpse0327 Sep 01 '15 at 06:39 PM

Maybe a bug?

My first thought was that SM not existing, but it does. So my assumption is a bug. But without being sure, i don't want to talk about it.

avatar image Corpse0327 Sep 06 '15 at 06:31 AM

For bumping reasons

avatar image gmc Sep 06 '15 at 03:50 PM

Idk if this will help but, I made a blank 4.9 project and just copied my content folder over and all of the reference errors went away. (All though I had way more than just 1 error and a lot of them were engine based, still worth a try though!)

avatar image Corpse0327 Sep 06 '15 at 05:32 PM

It would be really painful, but worth a try.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I cleaned up that blueprint. Reattached meshes and recreated nodes and functions from scratch. It fixed the problem for me. No need for recreating the entire project.

more ▼

answered Sep 08 '15 at 10:17 AM

avatar image

Corpse0327
186 26 25 35

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question