x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS launch crash related to Blueprint

When I launch on my iPad, my game crash, with a " TEST FAILED error" :

 LogPlayLevel:Display: env: 2014-04-14 12:38:37.520 UE4Game[4099:3b03] [2014.04.14-10.38.37:520][  0]LogWorld: Bringing World /Temp/Autosaves/Game/Maps/UEDPCTestMap.TestMap up for play (max tick rate 0) at 2014.04.14-12.38.37
 LogPlayLevel:Display: env: 2014-04-14 12:38:37.523 UE4Game[4099:3b03] [2014.04.14-10.38.37:523][  0]LogWorld: Bringing up level for play took: 0.013448
 LogPlayLevel:Display: env: ** TEST FAILED **
 LogPlayLevel:Display: env:
 LogPlayLevel:Display: BuildCommand.Execute: BUILD SUCCESSFUL
 LogPlayLevel:Display: Automation.Execute: Script execution successful, exiting.
 LogPlayLevel:Display: cp: log*.txt: No such file or directory

Game work fine on Mobile Preview and in Standalone.

I have successfully installed and launched the "MobileTemple" and "StrategyGame" on my iPad.

UE4 installation is the 4.0.2 origin version with no modifications and no self-compilation.

When on my project I break many links in a Blueprint class, the game launch fine. Breaking this 3 flows and the game run on iPad :

alt text

I don't understand why the project run fine in Mobile Preview, and why it crash on device ?

The complete log is included.

[2]: /storage/temp/4023-ue4_ios_launch_crash.txt.zip

Product Version: Not Selected
Tags:
more ▼

asked Apr 14 '14 at 12:47 PM in Packaging & Deployment

avatar image

Eddy71
76 7 11 21

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.

Thanks!

more ▼

answered Nov 25 '14 at 03:03 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 76

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question