x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash caused map corruption?

After working for 6 months on a project. I'm about to trash the entire thing and walk away. So many crashes day in and day out and today was the worst.

I started working on a map a week ago. I was about 90% done it today. Got a blue screen. Upon restart I get Failed to load map! appears to be an asset file.

The map exists in the content folder but i can't see it in UE editor. And I don't have a backup of it. Autosave is from a week ago.. wtf.... im just... defeated now.

Product Version: UE 4.8
Tags:
more ▼

asked Sep 02 '15 at 07:09 PM in Bug Reports

avatar image

thankstipscom
639 38 35 70

avatar image Jacky Sep 02 '15 at 07:14 PM

You sure there is no backup in the Backup folder?

avatar image thankstipscom Sep 02 '15 at 07:17 PM

Just saw that.. and there is from a half hour ago.

But when I try to load that one i get a

"Failed to open map file. This is most likely because the map was saved with a newer version of the engine."

avatar image Adam Davis STAFF Sep 02 '15 at 07:44 PM

Hi thankstips.com,

Do you have any copy on a source control system or FTP service that you can roll back to? Additionally, can you post a copy of your dxdiag here? The editor cannot specifically cause a blue screen, as that is a hardware related error. However if the computer ran out of memory during performance intensive tasks or if something was damaged that could lead to a bluescreen indirectly. If you transfer the .umap to a new, blank project are you able to open it?

avatar image thankstipscom Sep 02 '15 at 07:57 PM

Hey. The original umap doesnt show up in the editor in any project i transfer it to physically (obviously the assets would be missing in this case). I can't migrate through the editor for the same reason.

When I move the back up version of the map to a fresh project it shows up, but opening it appears to do nothing. Not even the engine version error or anything. Just nothing happens.

I dont think the dxdiag will help here, I know what casused the bluescreen. I opened marketplace to start DL of 4.9 and it downloaded faster than my RAID system can write and crashed the Achi driver. I recently migrated from an SSD only laptop to my main server because the video card is a 960 and the storage space is 10TB. The laptop wasn't cutting it anymore. Been running this rig for the last week or so. All my DL's are throttled for all other applications. Never thought about UE updates when starting the Dl for latest version unfortunately.

dxdiag

dxdiag.txt (80.3 kB)
avatar image thankstipscom Sep 02 '15 at 08:01 PM

sorry also no source control. Its a solo project at the moment. I do have regular scripts I use to back it up each night. I haven't migrated those from previous laptop yet. Been kinda head down focused, never got around to it.

avatar image thankstipscom Sep 02 '15 at 08:24 PM

Tried debugging through VS.

"Post Tag is not valid. File might be corrupted" when right clicking on the umap file.

avatar image Adam Davis STAFF Sep 02 '15 at 08:44 PM

Hi thankstips.com,

Did you receive any crashes other than the BSOD that could have led to the map corruption? Are you able to continue working on the rest of your project still or is the entire project corrupted? If the BSOD corrupted your map file there isn't much that can be done to save it without a backup copy or some form of source control (I highly recommend using this, even on a solo project it will allow you to revert to previous copies of assets).

avatar image thankstipscom Sep 02 '15 at 08:53 PM

is there no way at all to get inside the umap file and find out what is wrong with it. To even salvage some of it?

There were several crashes today. I get an average of 20 a day. Was able to resume working without an issue afterwards though until the blue screen.

avatar image Adam Davis STAFF Sep 02 '15 at 09:00 PM

Try creating a copy of the .umap and opening that instead of the original. Otherwise there isn't going to be much that can be done. If it is registering the map as a .uasset instead of a .umap due to corruption it will not be openable.

avatar image thankstipscom Sep 02 '15 at 09:08 PM

ya that was the first thing I tried. no luck. the backup file seems to get recognized as a map and is seen in the editor. how is the backup file created? its not much of a backup if it backs up a corrupt file. The size is slightly different than the corrupted one so its obviously different.. just dont know why its giving me an engine version error when trying to load that one.

Though they have the same modified date/time :/

avatar image Jacky Sep 02 '15 at 09:13 PM

What happens if you name the backup file the same as the corrupt one > copy/paste and overwrite the corrupt one with the backup map? Do you still get the same errors? If this doesnt work either it looks like the project itself got corrupt with the crash, not just the maps. : \

avatar image thankstipscom Sep 02 '15 at 10:10 PM

ya no luck,

i got to a point where I right click it and it says no failed to load assets. One of my assets was corrupted. I replaced it and that went away. Then all my AI EQS stuff was "notfound", somehow the plugin got disabled after the crash. I reenabled it and all of the warnings went away. So now it says failed to load assets but the log window opens empty and it says the map was checked without errors. Double clicking on it does nothing.

other maps seem to load up without issue.

sigh thanks anyway

avatar image thankstipscom Sep 02 '15 at 10:41 PM

just an epic day overall it seems.

alt text

avatar image Adam Davis STAFF Sep 03 '15 at 03:17 PM

Is it saying your editor is corrupted now? I'm a bit confused by your most recent post.

avatar image thankstipscom Sep 03 '15 at 03:35 PM

Just when trying to upgrade to 4.9, couldnt upgrade at all. But 4.8.3 had some weird things. Some of my assets couldnt be read despite the files being ok in the content folder. I replaced these with "working" versions. which were ok. Plugins reverted to defaults, EQS was off..

I was clinging to a 1% chance that maybe a conversion to 4.9 would allow my map to be read.

So I un-installed and deleted all unreal everything. Reinstalled on a single drive. 4.9 and 4.83 both working now. (still using 483). Map is def not recoverable. Working off a single drive. will backup to the larger array daily. Sucks...its like art, wont be able to create the map the same way again. The functions in it are easy enough to redo. Can close this. I dont think any real resolution for map corruption will come. Just need to ensure to back things up on your own as well. Thx for follow up.

avatar image thankstipscom Sep 03 '15 at 03:39 PM

All other maps are still working fine so the project wasn't corrupted. But i have many backups of the project prior to beginning this map ironically.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi thankstipscom,

I'm going to mark this thread as answered for tracking purposes.

more ▼

answered Sep 03 '15 at 05:28 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question