x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Showdown VR Demo Build 4.9

When we try to build Win64 in 4.9 we get a failed build with the error

MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 35.0279915s to run UE4Editor-Cmd.exe, ExitCode=1

MainFrameActions: Packaging (Windows (64-bit)): Project.Cook: Cook failed. Deleting cooked data.

MainFrameActions: Packaging (Windows (64-bit)): BuildCommand.Execute: ERROR: BUILD FAILED

MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception:

MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: Exception in AutomationScripts.Automation: Cook failed.

MainFrameActions: Packaging (Windows (64-bit)): Stacktrace: at Project.Cook(ProjectParams Params)

MainFrameActions: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params)

MainFrameActions: Packaging (Windows (64-bit)): at BuildCommand.Execute()

MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)

MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String[] CommandLine)

MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param)

MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param)

MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Program.Main()InnerException in AutomationUtils.Automation: BUILD FAILED: Failed while running Cook for C:\Users\admin\Documents\Unreal Projects\ShowdownVRDemo\ShowdownVRDemo.uproject; see log C:\Users\admin\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+4.9\Cook-2015.09.02-12.54.12.txt

MainFrameActions: Packaging (Windows (64-bit)): Stacktrace: at AutomationTool.CommandUtils.RunCommandlet(String ProjectName, String UE4Exe, String Commandlet, String Parameters)

MainFrameActions: Packaging (Windows (64-bit)): at Project.Cook(ProjectParams Params)

MainFrameActions: Packaging (Windows (64-bit)): ProcessManager.KillAll: Trying to kill 0 spawned processes.

MainFrameActions: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=Error_UnknownCookFailure

MainFrameActions: Packaging (Windows (64-bit)): Domain_ProcessExit

MainFrameActions: Packaging (Windows (64-bit)): copying UAT log files...

MainFrameActions: Packaging (Windows (64-bit)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.

MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED

PackagingResults:Error: Error Unknown Cook Failure

Product Version: UE 4.9
Tags:
more ▼

asked Sep 02 '15 at 10:10 PM in VR

avatar image

daveSchoneveld
16 1 5 8

avatar image BrainBash Sep 03 '15 at 02:36 AM

I'm getting the same error.

avatar image makhras Sep 03 '15 at 03:09 PM

Same error. And I can't even get it to play at all... So much frustration....

avatar image Otreum Sep 08 '15 at 10:09 AM

Tested the compile because my 4.8 project which I migrated to 4.9 no longer compiles either. I figured I'd try compiling the VR demo, and it failed, just like most people are reporting. Annoyingly with an unknown cook failure, which is very non-descript :(

avatar image Thomas.M Sep 09 '15 at 12:10 AM

if you read the full log file it tells you exactly where it failed. the summary is useless :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

When loading in 4.9 i found and error in /Game/Audio/Blueprints/Surrondpanner

in the event Graph: GetWorldRotation and GetTargetLocation were invalid and pointing at self

to fix I Replaced the two invalid function instances with a valid target "AudioCenter"

I cooked and played and audio tracked head movement properly.

more ▼

answered Sep 04 '15 at 05:54 AM

avatar image

Thomas.M
21 1 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The demo is working for me with 10.4. Did you try with the latest updates?

more ▼

answered Mar 04 '16 at 10:00 AM

avatar image

devel.bmad
439 43 49 65

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Its been working since 4.9+ so this thread can be closed.

more ▼

answered Mar 04 '16 at 01:57 PM

avatar image

daveSchoneveld
16 1 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question