x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Matinee bug with custom component?

Here's the setup:

  • I have a blueprint class derived from actor ("TestActor"), that I attach a cube component.

  • I've created a custom component that saves a file "cmp_created" on component creation and saves a file "cmp_dosth" when I execute a function from that component, say "DoSomething()"

  • I add the component to TestActor in the blueprint editor, and I set it to auto-activate

  • I connect the DoSomething() function to EventBeginPlay() of TestActor

In editor, it plays fine, and both files are created
In matinee movie, none of the files are created (So, the component is not created at all??)
If I disconnect DoSomething() from EventBeginPlay and I run matinee movie, only "cmp_created" is created

Question: is this a bug, or there is something magical that I need to do in order to use a custom component at BeginPlay when using Matinee?

Product Version: UE 4.8
Tags:
more ▼

asked Sep 03 '15 at 11:05 AM in Bug Reports

avatar image

BabisK
26 1 5 7

avatar image Logan Bailey ♦♦ STAFF Sep 03 '15 at 07:46 PM

Hello BabisK,

So there a bit more information that I need from you.

  1. Will you link a screenshot of how you have your BP set up and how you are calling Matinee.

  2. Will you link a screenshot of matinee and the editor where the files are/are not being created.

  3. Do you have a director track added inside of matinee.

I suspect that you are not calling the files to be created inside of matinee. However, with the above questions I should be able to narrow down the list of possibilities.

Thank you,

Logan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello BabisK,

Due to inactivity and tracking purposes I will be marking this thread as closed. If you are still having a problem then please post again. I will then continue to investigate this issue at that time.

Thank you,

Logan

more ▼

answered Sep 09 '15 at 01:12 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question