x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How can I remove tonemapping in Play mode?

Hi all.

I can't remove tonemapping in "Play" mode. I have setting Post Process Volume and setting off whole parameter and check "unbound(that is override)."

But I have realized tonemapping when I enter the "Play" mode.

I can see tonemapping removed situation in "Edit" mode. That is turned off all of the Edit mode viewport's show > Post Processing check.

However, I want to see tonemapping removed situation in "Play" mode.

Please tell me if someone know about the solution.

Product Version: Not Selected
Tags:
more ▼

asked Apr 14 '14 at 04:09 PM in Rendering

avatar image

Polytrash
18 3 5 6

avatar image Jacky Apr 14 '14 at 04:13 PM

Can you post a screenshot of your post process settings? Maybe there is something you are missing.

avatar image Polytrash Apr 15 '14 at 01:38 PM

Hi Jacky.

Thank you for reply.

I have attached screenshot of my post processing volume Details and compared image of Edit mode with Play mode.

alt text

postprocessing.jpg (313.8 kB)
avatar image Polytrash Apr 15 '14 at 01:40 PM

alt text

viewport.jpg (431.7 kB)
avatar image Jacky Apr 15 '14 at 02:03 PM

Strange. Can you try setting Min and Max Brightness values of Auto Exposure to 1 and see if it helps? Also, do you have LPV enabled for your light source?

Awesome job with screenshots, btw! I appreciate it. :)

avatar image Polytrash Apr 17 '14 at 01:13 AM

Yes,it is strange. I also think so.

Btw, I have turning on my LPV ,but nothing changed unfortunately...

I can't believe this design about the tonemapping. Because if user won't turned off the tonemapping, user won't achieve photoreal graphics. That is user have to compare with biased tonemapping image with reference(especially linear images or color corrected images).

Otherwise, user have to add odd bias again.

It is a bit adverse to the art workflow:(

p.s. I'm glad screenshot was of help to you:)

avatar image Jacky Apr 17 '14 at 01:30 AM

This shouldnt be happening normally, so now i'm guessing either something is broken in the scene or it's related to your system.

About LPV, i was going to ask you to turn it off if you had it on, so you can turn it back off.

Now, what happens when you create a new project? Do you still get the same viewport - game difference? Also, are you using a Mac? There are some reports on lighting issues with Mac's so thats another thing that comes to my mind.

avatar image Polytrash Apr 17 '14 at 05:52 AM

I assayed this on my office PC and my private PC, however the problem has occurring both system and both is Win.

I attached other image. I have created entire new simple scene, and then I placed box and one directional light, and finally placed player start point.

Of course I could turn off all post process or some other thing including affect to view in edit mode.

But when I enter the Play mode, I have realized same tonemapping problem, and then I couldn't fix it by full zero setting PostProcessing Volume...

That is just same situation with customized scene:(

I need clear advice from EPIC.

alt text

.

ppv_compare.jpg (204.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

On begin play, run the ShowFlag.Tonemapper 0 command.

alt text

more ▼

answered Sep 07 '16 at 07:37 AM

avatar image

Douglas Lassance
288 17 17 28

avatar image 8poundgorilla Mar 19 '17 at 07:27 PM

Fist let me say that I've only been playing with these tools for a few weeks so forgive me if I come off as ignorant.

While making my way through some video tutorials for Paper 2D, the color fading I was seeing in my sprites was kind of painful. This was the first simple solution I found that actually worked. While this does feel like more of a workaround to a limitation of the tools it does work quite brilliantly. That being said, disabling tone mapping did have some adverse effects such as losing glow effects in materials.

I guess what I am trying to figure out is a) whether this is a "use at your own risk" type of solution and b) if this is still the current best approach or new options have been added to the engine over the last several months (especially for Paper 2D).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Tonemapping is the term convert an HDR color (very bright and very dark as it happens with lighting) to an LDR color (limited by range as monitors cannot be brighter than white). Is this what you want to disable? The tonemapper curve is softly clamping off the whites and does a slight contrast enhancement.

I assume you don't want eye adaptation. If you set min brightness and max brightness to 1 in the eye adpatation settings it will be fixed. In the editor there is a menu where this can be done as well - this is useful for editing purpose. If you have the editor feature enabled (you can find it in the viewport menu) - you get a different behavior in game/editor.

LPV should not affect this.

more ▼

answered Apr 21 '14 at 02:47 PM

avatar image Polytrash Apr 21 '14 at 03:48 PM

Hi Martin.

Thank you for answer my question.

Yes, Your presume is right. I don't need eye adaptation tonemapping, because I'm trying to make camera adaptation scene in UE4.

Generally, eye adaptation tonemapping is just a simulation of human eye, but I think it isn't conclusive simulation. So I've chosen to make camera simulation scene, that is camera linear image that from camera raw data. It is similar approach with film.

I've gotten this simulation with cryEngine's game mode actually by compared with camera linear, because cryEngine was easy to kill the whole post process.

In fact, tonemapping will become a noise in this situation.

I guess if I won't remove tonemapping in UE4's play mode, I can't achieve well-reasoned photorealistic visual with UE4.

That is a reason why I want to preclude the tonemapping in Play mode.

avatar image Martin Mittring STAFF Apr 21 '14 at 05:57 PM

We have a misunderstanding. Tonemapping is HDR->LDR, EyeAdaptation is normalizing the HDR based on content.

I explained how to disable eye adaptation. Tonemapping is still happening. Our tonemapper pass also does add noise to reduce color quantization for 8 bit, apply color grading from LUT texture and other things. All that also works together with otehr features e.g. TemporalAA which assumes a tonemapping step.

If you disable tonemapping (=linear tonemapper) you would get clamped highlights. That looks quite bad.

If you want to export some color like GBuffer properties - you don't need to disabale the tonemapper, you can access the HDR intermediate.

You also can change PostProcessTonemap.usf. We intend to make the postprocessing more programable - then you can do such a change in the material editor.

avatar image Polytrash Apr 22 '14 at 02:10 AM

I understand your answer.

I should had to mentioned about "Linear Tonemapper" and HDR > LDR process,sorry for my deficient explanation.

I had assumed user turn off the tonemapping checkbox in the editor view as well as can remove the tonemapping but it is difficult to solve current maybe.

However I'm glad to hear UE4's tonemapping will become more programable. I look forward to seeing this feature:)

avatar image CWeatherman May 16 '14 at 05:40 PM

For anyone who happens upon this thread, this problem has also become a point of discussion here:

https://answers.unrealengine.com/questions/44088/gammatone-washing-out-image-how-to-fix-1.html

avatar image schmigel Sep 13 '16 at 04:27 AM

The discussion continues... in the link above https://answers.unrealengine.com/questions/44088/gammatone-washing-out-image-how-to-fix-1.html

I have a scene with no lights, that looks complete dark in the viewport. Then I hit play and what I get its a grey scene. I explain more in the discussion.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question