x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Vive locked at 60 fps

When we run the VR preview in editor for the first time with our Vive, the framerate is solid at 90fps. Trying to run the VR preview in editor a second time results in the frame rate getting locked at 60fps. Even if no changes have been made to the scene. This means we get one good preview in editor before having to shutdown UE4 and restart it.

We've checked with and without the "smooth frame rate" enabled, and toggled vsync on and off in our Nvidia graphics settings.

All builds are locked at 60fps. Is it locking the framerate to the primary monitor? Any ideas would be appreciated. We're running a beast system with a 980ti.

Thanks in advance.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 03 '15 at 10:14 PM in VR

avatar image

BeaverCleaners
16 1 2 3

avatar image zalo Sep 08 '15 at 09:20 PM

Have you tried overclocking your main monitor to 90hz or setting the Vive as your main screen?

avatar image Rudy Q ♦♦ STAFF Sep 09 '15 at 03:15 PM

Hello BeaverCleaners,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. if so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide your dxdiag?

  4. Was your project upgraded from an older version of the engine?

  5. If so, what was the upgrade process?

avatar image BeaverCleaners Sep 10 '15 at 05:36 PM

Hi Rudy,

Yes, this issue exists even if it is a new project. We've tried with new 4.9 projects and with upgraded projects but the issue remains.

Changing the monitor settings (Vive as main monitor, secondary, etc.) and overclocking the refresh rate have not fixed the issue.

Repro Steps:

1 - With the Vive connected, launch the 4.9 version of the editor.

2- Create a new "First Person" project (either Blueprint or C++) using Desktop, Maximum Quality and with Starter Content.

3 - With VR Preview mode enabled, choose Play in editor.

4 - On this first preview use the "stat fps" command, the framerate is able to hit 90fps.

5 - Exit the VR preview.

6 - Choose Play in editor in the level once more. The FPS is now locked to 60fps.

7 - Close UE4 and then re-open the same project.

8 - Run VR preview again and the FPS is able to hit 90fps again.

I'm attaching my dxdiag as well.

Thanks for the help!

Craig

our dxdiag

dxdiag.txt (76.1 kB)
avatar image Rudy Q ♦♦ STAFF Sep 11 '15 at 01:08 PM

Hello BeaverCleaners,

I thank you for the information provided. However, I do have another question for you. Are you currently experiencing this issue on a laptop? If so, could you try this on a desk top and/or try modifying your performance settings? The laptop may be throttling performance to save battery life.

avatar image BeaverCleaners Sep 13 '15 at 06:10 PM

Hi,

It is actually a desktop machine, not a laptop. It has an i7-5960X 8-Core processor, 64GB of DDR4 RAM, a 1200W power supply and an Nvidia GTX 980ti. The Vive is running at a solid 90fps in Unity 5.2 as well so it doesn't seem like a hardware issue.

avatar image dbulla Sep 09 '15 at 04:37 PM

When this happens are you seeing the editor viewport in your headset?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello BeaverCleaners,

I am happy that you were able to find a workaround for this issue. I have written up a report ( UE-21310) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered Sep 21 '15 at 08:03 PM

avatar image

Rudy Q ♦♦ STAFF
48.1k 544 132 520

avatar image NickZucc May 22 '16 at 03:00 PM

I just started to develop with the VIVE, the device is auto set to be in direct mode, the only way to try this screen technique is to take the VIVE of of direct mode and position the screens as you are showing. When in UE4 this is actually casing the jutter to be even worse. Sickening worse! In Direct mode I am getting frame rates of about 45 fps when on the DK2 I was getting a steady 75fps. Is anyone from Epic aware of this situation in direct mode? Is there an eta for a fix?

avatar image Rudy Q ♦♦ STAFF May 23 '16 at 01:53 PM

Hello NickZucc,

After speaking with the developers and reading over the report mentioned above, I was able to find out that this issue is on Valve's end. This being the case, you will need to speak with Valve for more information. I hope this helps.

Make it a great day

avatar image DFin May 23 '16 at 03:55 PM

Hey Nick,

The original issue that OP mentioned is completly solved with direct mode. If you hit 45fps in direct mode it's a performance issue on your side and you don't hit 90fps. If the frame rate is lower than 90 it drops to 45, because it has to wait for V sync. If your VR experience runs with lets say 85 fps on your system (without V sync) it would run fine with 75 fps on DK2 but only on 45 fps with the Vive because of the sync to 90Hz.

I don't think that there will be a fix for this issue as it is fixed with direct mode and extended mode is more or less deprecated.

Does your issue happen in a new empty it Unreal project? What are your Hardware specs?

(comments are locked)
10|2000 characters needed characters left

I experienced the same issue. The cause is most likely that unreal editor overlaps the second screen when in fullscreen, as explained here: http://steamcommunity.com/app/358720/discussions/0/523890681427232040/

Compositor isnt fullscreen then -> 60fps lock.

A workaround is to place the second screen below and to the right of the first: alt text

If the problem still persist make sure that the preview window on the primary screen doesnt overlap when opened.

monitors.jpg (18.1 kB)
more ▼

answered Sep 16 '15 at 08:59 PM

avatar image

DFin
36 1 4 10

avatar image BeaverCleaners Sep 16 '15 at 10:26 PM

This solved the issue for us. Thank you! We dropped you a line on Reddit as well. Cheers!

avatar image Dustums Sep 18 '15 at 03:25 PM

This worked for me as well, though not as exactly described. If I moved the Vive screen down and right the problem still happened. My preview window must have been touching both bottom and right. Instead, I moved it to the lower left of my second monitor, as shown below, and it works now. Thank you so much for the advice. You're a life saver. alt text

Is there a way to check directly if the compositor is running in full screen or not?

screensetup.jpg (18.0 kB)
avatar image Tom Looman Jan 06 '16 at 08:26 AM

Thanks a lot guys! This solved my sickening jittering issues I've been having for weeks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question