x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AIPerception bug

So I was just troubled for about 5 hours trying to figure out why my AI stopped perceiving my player (stopped perceiving everything altogether), but i finally found the cause of the problem.

If my landscape (and corresponding AI and nav mesh) are around -1000 - 0 the AI does not perceive anything, but if I raise the landscape it functions as expected.

As you can see in these 2 pictures, the first, I am not being perceived by the AI, in the second, I am. The ONLY difference is the Z value in the transform. There are no level blueprints affecting this either.


EDIT: Coming back to it after having saved it with everything at a higher height, it seems like adjusting it now I am able to put it to any height and the perception works. But, in the process of debugging I did close and re-open the project multiple times, rolled back to previous versions of the AI and player class, just to make sure I didn't break anything, but ultimately it was rolling back the level that solved the glitch, simply because the previous version of the level was at a greater height (z value). And indeed, in my testing earlier, AI perception was failing to recognize any type of actor (tested on 2 different landscapes, both < 0 in Z, which was remedied when I brought them up a few thousand cm

alt text


alt text

Product Version: UE 4.8
Tags:
notworking.png (2.1 MB)
working.png (2.0 MB)
more ▼

asked Sep 04 '15 at 12:21 AM in Bug Reports

avatar image

HuntaKiller
160 9 12 19

avatar image Adam Davis STAFF Sep 04 '15 at 03:12 PM

Hi HuntaKiller,

Does this occur in a clean, blank project with no additional content or is it limited to one project? What is your killZ set to in your world settings? Is the area encased in a navmesh bounds volume?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi HuntaKiller,

We have not heard from you in several days. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment back with the requested information.

more ▼

answered Sep 08 '15 at 05:18 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question