x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Smartlinks in 4.9 won't update

I have some navlinkproxies in which I use only smartlinks and have removed the points links. If I move them around in the editor they get updated and show the navlink arrows. But if I change positions on them from code and refresh the navigation in the Octtree it doesn't update. I don't know if they somehow doesn't get added to the octtree ? Disabling/Enabling the smartlinks hasn't worked since 4.7 but I found that if I moved the navlinks they did update which then functioned as a workaround for enabling/disabling smartlinks but now in 4.9 none of the options work.

My navigation mesh is set to dynamic and reacts to changes in geometry runtime.

Could you please take a look at this ? It is an essential thing for our game to be able to enable/disable smartlinks on navlinkproxies.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 04 '15 at 08:36 AM in Using UE4

avatar image

Robin.UltraUltra
36 2 5 8

avatar image Robin.UltraUltra Oct 22 '15 at 07:25 AM

Does anyone know if this is fixed in 4.10?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks for reporting this bug. Link components from NavLinkProxy actors are not registering themselves properly in navigation octree due to uninitialized bounds.

Please try following workaround: add smart link relevancy to NavLinkProxy, by changing function ANavLinkProxy::IsNavigationRelevant to:

 bool ANavLinkProxy::IsNavigationRelevant() const
 {
     return (PointLinks.Num() > 0) || (SegmentLinks.Num() > 0) || bSmartLinkIsRelevant;
 }

more ▼

answered Oct 26 '15 at 09:54 PM

avatar image

IceWraith STAFF
426 13 7 20

avatar image Robin.UltraUltra Oct 27 '15 at 07:41 AM

Thanks a lot for this answer ! I will try this solution as soon as I get the time to and then I'll get back to you here and report if it works.

avatar image Robin.UltraUltra Nov 23 '15 at 08:19 AM

This worked just as you said, perfect! Thank you and keep the good work up :)!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question