x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.9] No DefaultInput file generated if missing in checked out project

We've recently switched to 4.9. One of our developers has created a new C++ project and submitted all auto-generated files to source control (Subversion).

After checking out the project (in TortoiseSVN, not Unreal lingo), I wanted to create some new input mappings. So I opened the ProjectSettings and switched to the Input category.

What happened next was that the project idled for a while, attempting to load (or create?) the settings file. I waited about 10 minutes before I gave up. When I checked the Config folder, I noticed that no DefaultInput.ini existed, so I copied an existing file from another project into the Config folder. After that, I was able to access and edit the input settings.

Later in a reproduction attempt, I tried creating my own C++ project locally. As before, the DefaultInput.ini didn't exist initially. However, this time as soon as I picked the Input category in the ProjectSettings, the file was immediately autocreated.

As far as I can tell, the only difference was that I hadn't created the former project myself and that it was connected via Source Control. A co-worker also tried changing the input settings and experienced the same problem.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 04 '15 at 10:24 AM in Bug Reports

avatar image

erinacea
1.8k 69 28 114

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey erinacea-

I tried to recreate this issue using Perforce. I created a new C++ project and confirmed that the DefaultInput.ini file did not exist before adding the project to source control. I then had a teammate sync to the project and confirm that they did not have the ini file before opening the project. Inside the editor he was able to open the Input tab which opened immediately and was able to be edited. The DefaultInput.ini file was created locally for him at this point. Let me know if there is something I've done differently in my test or if there is something I've missed

Cheers

Doug Wilson

more ▼

answered Sep 04 '15 at 02:36 PM

avatar image erinacea Sep 04 '15 at 03:29 PM

Once we got it running (with the copied ini file), we didn't experiment any further. We're using Subversion, though. Also, we're doing all our version updates via TortoiseSVN outside the editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question