x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

after 4.7->4.9 map crash (maybe D3D11 related)

One of our maps (only one) crashes when loading (both from a running game and when opening in the editor) after upgrading our project to 4.9. link text

 Access violation - code c0000005 (first/second chance not available)
     
 UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHISetStreamSource() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\windows\d3d11rhi\private\d3d11commands.cpp:107]
 UE4Editor_ShaderCore!FVertexFactory::Set() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\shadercore\private\vertexfactory.cpp:177]

...

I have attached the crash details. So far i havn't been able to get it to work and i have tried redoing the procedure going from 4,7->4.9 but it gives the same result. Any ideas of what might cause this / how i might be able to get it to work?

Product Version: UE 4.9
Tags:
crashcontext.zip (75.9 kB)
more ▼

asked Sep 04 '15 at 02:18 PM in Bug Reports

avatar image

Vejgaard
55 6 9 14

avatar image Matt.Williams Sep 04 '15 at 07:51 PM

Hey Vejgaard,

Thanks for sending a thorough package of info for me. I was able to find a matching crash in our system, but it appears that it was supposed to be fixed in 4.7.

This leads me to believe the bug is still there, but simply under different repro steps.

Would you be willing to send me the 4.7 version of your project so that we can reproduce this in house? If you'd rather not send the whole project, you could try using the migrate functionality to bring the problematic map into a blank 4.7 project and send that.

If you choose to migrate the map, could you ensure that it still crashes on your end after upgrading to 4.9? Just to be sure

You can upload to Drive, Dropbox, etc and then PM Me the link on the forums.

-Matt W.

PS - Leaving this for my own tracking purposes, but the bug in the system is UE-8096

avatar image Matt.Williams Sep 15 '15 at 05:17 PM

Disregard the previous comment(deleted now), it was just taking a while to load the drive page. Thanks for sending that along though.

avatar image devlyn811 Feb 23 '16 at 03:16 AM

Is there any update on this issue?

avatar image Vejgaard Feb 23 '16 at 12:09 PM

For me the issue disappeared with 4.10

avatar image devlyn811 Feb 23 '16 at 02:10 PM

That's good news! - Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey Vejgaard-

I'm still not sure what exactly is causing this crash. I have entered a bug report for this crash based on the information available (UE-21411).

Cheers

Doug Wilson

more ▼

answered Sep 23 '15 at 06:18 PM

avatar image Vejgaard Oct 15 '15 at 06:38 AM

Hi again, any news on UE-21411?

avatar image Doug E ♦♦ STAFF Oct 15 '15 at 01:57 PM

Hey Vejgaard-

UE-21411 is still open to be worked on. I will update the bug report to reflect the growing interest and will respond here when there is an update to the status of the bug.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm still working on this issue, but just wanted to pass along a suggestion to try converting to 4.8 before going all the way to 4.9.

more ▼

answered Sep 15 '15 at 06:47 PM

avatar image Vejgaard Sep 16 '15 at 10:35 AM

Hi Matt. I tried making a copy and going through 4.7->4.8->4.9.1 and it seems to work! So far i havn't been able to replicate the bug through this method... This seems promising enough that i will start upgrading on a branch of our repository and do all code changes to make our game work fully in 4.9. You can consider our problem solved, i will get back to you if anything pops up! :)

avatar image Matt.Williams Sep 16 '15 at 02:10 PM

Yeah our code support guys were saying that it's best to upgrade one major version at a time. I'm glad it worked. Happy developing!

avatar image Vejgaard Sep 17 '15 at 08:36 AM

Hi again Matt. I'm sorry to say that after a little more thorough testing of the upgrading method, the bug still seems to be there. I can open the map separately and then play it, but if i go through our menu it will produce the same bug

avatar image Matt.Williams Sep 17 '15 at 02:53 PM

I'm getting compile errors when I switch the engine version to 4.9 and recompile. Can you tell me how you're getting it to work?

avatar image Vejgaard Sep 18 '15 at 06:40 AM

I send you a PM with some cpp files that should be enough to get it to work. There were some changes that in the engine that makes the project a little unstable without changes to the blueprints too, but you should be able to reproduce the bug.

avatar image MSE_Taliesin Sep 22 '15 at 04:14 PM

We're getting this crash, too. We're using the code from Git, and we upgraded to 4.8 and stayed there for a while before upgrading to 4.9, so I don't think that's the issue.

https://answers.unrealengine.com/questions/300534/d3d11-crash.html?sort=oldest

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We have seen the same crash. If you delete the Intermediate folder and run again, the problem dissappears but might comeback later (after several days, probably depending on how much we changed the game). That's probably why Vejgaard issue was "fixed" when converting the projects from one version to another (but I suspect it might come back anytime).

more ▼

answered Sep 23 '15 at 06:49 PM

avatar image

ThierryV
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question