x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light building stuck at 99%

Hello, please I need some help. After converting my project from 4.7 to 4.9, the light building gets stuck at 99%. Before doing that, light building took aprox 2-3 minutes (its a simple scene).

I have tried: Leaving it for 3 hours building the lights. Building lights in Production and Preview quality. Deleting groups of actors in the scene to spot if one is causing trouble (went as far as deleting every actor and lights wont build). Creating a new 4.9 project and building lights, builds OK.

Extra info: Projects uses dynamic directional light, no static lights (as for now, can and probably will change in the future) It's a VR project using Oculus 0.7 SDK. Not sure if necessary but: Windows 8.1, i7-4930k, GTX 780, 32 gb ram.

Thanks for your help.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 05 '15 at 07:01 PM in Rendering

avatar image

elTomkinson
22 5 5 7

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hello,

I had the same problem.

I succeeded to resolve it by changing the settings of my LightmassImportantVolume. At first I made it bigger with scale ( Transform ), and my light building was sticking like you. I tried to put the scale to ( 1.0, 1.0, 1.0 ) and make the volume bigger with the Brush Settings. Since this moment, my lights build successfully. I put a picture with my new settings with scale to 1 and brush settings changed.

Maybe it is just a coincidence, hope it can help anyway.

alt text

more ▼

answered Sep 06 '15 at 02:54 PM

avatar image

Lilyël
96 2 7 10

avatar image elTomkinson Sep 11 '15 at 12:05 AM

Yes! That did the trick. I was able to build the lights. Thanks!

(comments are locked)
10|2000 characters needed characters left

Try the options in the Clean and Validate section of this Troubleshooting guide: https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting

Just so you're aware, if you're using a fully dynamic (movable) light Building lighting is not really going to affect anything since movable lights don't bake lightmaps.

You really shouldn't need to build lighting at all. There are other things that are building when this process happens though that may be causing a hitch, but I'm not sure off-hand. Try first using the guide above and see if that helps. If not, for the time being, while you're not using static lighting you can go to the World Settings > Lightmass > and put a checkmark in the box for Force No Precomputed Lighting. This will disable all static lighting. Then try to rebuild. If it's still getting hung at 99% there is potentially something else causing it to do so and not Swarm Agent.

more ▼

answered Sep 05 '15 at 11:42 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 876

(comments are locked)
10|2000 characters needed characters left

it took me almost 5 hours to complete with all quality settings at maximum reflexes and effects

Intel Core I5 GTX 1060 6GB 12GB RAM

relax because it takes time

more ▼

answered Jul 07 '18 at 04:36 PM

avatar image

TheSubZer0
114 7 11 16

avatar image TheSubZer0 Jul 07 '18 at 04:39 PM

check the task manager if ue4 uses 60% or more of your CPU.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question