x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Quitting from pause menu to main menu doesn't open main menu properly

I have just started fresh with a blank project. I have two levels, a main menu and a "world level". When I start my game it opens the MainMenu which has only 3 buttons and Title Text. When I hit Play it opens my world that shows the blank starter environment and two on-screen mobile twin stick controllers. When I open my Pause menu and try to Quit to the main menu, it leaves the sticks on screen from the world menu. I have separate pawns, characters, and game-modes for the main menu and the world, so I am not understanding what is casting the controllers on-screen in my "world" and why they don't disappear when I quit to the main menu?

alt text alt text alt text alt text alt text

Product Version: UE 4.9
Tags:
more ▼

asked Sep 06 '15 at 01:41 AM in Blueprint Scripting

avatar image

Anthony Ricciardi
3 1 2 4

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Create a new Touch Interface that doesn't map any analog sticks, and assign that interface as the active interface when you load your main menu level.

more ▼

answered Sep 07 '15 at 04:37 AM

avatar image

jwatte
1.3k 48 41 88

avatar image Anthony Ricciardi Sep 08 '15 at 11:13 PM

This worked for me, thanks, although it leaves me with a level of un-easyness still. If I leave them there and just set the opacity to 0, the sticks would show up for one second and then disappear, even with all the timing settings tweaked it would still just pop on/off. Removing them entirely did work though, thanks!

(comments are locked)
10|2000 characters needed characters left

You need to removeFromParent(self, or some other widget reference) BEFORE opening the level.

You can also do a getAllWidgetsOfClass(widget and another one for userwidget) then do a for each loop and remove them all plugging the index reference into a remove from mparent node and unchecking top level only.

Just the wrong order is all.

I also highly suggest you create a custom HUD class (right click -> blueprint classs -> all classes "HUD" since hud is the engine default the problem could be that alone.

Basically once you use the openlevel node in blueprints, nothing is accessable in memory anymore until it loads that level.

Don't forget to accept an answer that best clears your question up or answers it so when the community finds your question in the future via search/google they know exactly what you did to fix it/get it going.

more ▼

answered Sep 06 '15 at 03:28 AM

avatar image

Nsomnia
1.8k 67 27 137

avatar image Anthony Ricciardi Sep 06 '15 at 04:27 AM

What you posted was my original setup of nodes but it had the same result, I have also tried to run the loop of removing from parent but I do not think this is a widget problem since the controllers have nothing to do with that, does it? I created a custom HUD class but it hasn't changed the result.

Even though my game modes, characters, and controllers are different for the main menu and rungame levels, I don't know why it would:

A) Not show up when the game starts the main menu for the first time or B) Why it does stay on when you quit back to the menu

Besides gamemode, character, pawn, and controller is their anything else that could be loaded and taken into my main game? I think when I created my main menu level I used the "Empty Level" option and when I started my second level I used the "Default" option, is the Default Level loading something in that is missing by my Empty level?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question