x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Strange line and culling errors? (can't identify properly the source of the issue) ["solved"]

Hi,

I encounter an error that is quite strange. I get weird lines drawn on my cube faces.. Those " lines" move with the orientation we look at the cube from.

Here are 3 examples: alt text

alt text

alt text

I have absolutely no idea of the reason that is causing those "lines".

There is also another problem with the culling? (I guess?). Here are 3 screens showing what happens:

alt text

alt text

As you can see, for some reason my meshes are getting "eaten". I am searching for a little bit for the reasons but found no solution so far. :/

Product Version: UE 4.9
Tags:
more ▼

asked Sep 06 '15 at 05:57 PM in Rendering

avatar image

Hayaweh
182 12 20 76

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Alright...

I found a way to "fix" it.

I just did end up in replacing all my config file at the exception of the DefaultInput one and it now seems to be gone. I could not say what caused it though.

more ▼

answered Sep 06 '15 at 10:00 PM

avatar image

Hayaweh
182 12 20 76

avatar image Bariudol Sep 07 '15 at 01:59 AM

Good to now you found a solution.

(comments are locked)
10|2000 characters needed characters left

That looks like the shadow bias for your light is too low. If you are using a movable directional light check if the bias is too close to 0. Your other problem is not an occlusion culling problem, it looks more like z fighting or an aliasing problem due to low resolution or duplicated faces in your geometry (its not clear in the screenshots). Have you tried to see if this happens when using immersive mode? (press F11 while in editor).

more ▼

answered Sep 06 '15 at 07:22 PM

avatar image

Bariudol
886 21 13 29

avatar image Hayaweh Sep 06 '15 at 08:28 PM

Thanks for your answer. :)

The shadow bias is at 0.5, the default value, I tried increasing to 1 without any result. As for the lighting, it is coming from different point lights which are very far away in the world.

I tried the Immersive mode on your recommendation but it did not show any difference. In fact, the further away I go from the blocks, the more the issue shows.

Here is what is happening when I get a away more progressively. I will post the image links directly so that you can see it in a better way:

alt text http://puu.sh/k2eMZ/01cb85ebde.jpg

alt text http://puu.sh/k2eTV/2ab92565bf.jpg

alt text http://puu.sh/k2f3B/77bbcfd52a.jpg

alt text http://puu.sh/k2fyD/bbc3bbd820.jpg

You can see this sort of toothed line at the back of the cube. It is moving up and down when I move forward/backward and corresponds to the sort of lines seen in the first screenshots up there.

I don't think that resolution is the issue either as I just tried it with Immersive without any more results. I also tried with the three types of AA available without noticing any difference.

avatar image Hayaweh Sep 06 '15 at 08:33 PM

Update (already yes):

Seems like it happens in editor without being in play mode too:

alt text http://puu.sh/k2gfP/07dede61a5.jpg

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question